[Benchmarking] Odd results in qix index comparison

Andrea Aime aaime at opengeo.org
Thu Sep 2 05:27:15 EDT 2010

I was looking into the qix indexes this morning and decided
to use shptreevis to compare the qix index built by GeoServer
on contour-0 with the one used by MapServer on the testing server.

The result left me quite surprised: it seems the MapServer one
is missing an entire spain region?
See the screenshot of qgis displaying the layout of the two indexes
from GeoServer and MapServer. The mapserver one is in blue,
the geoserver one in black.
The same seems to be happening for other contour shapefiles
as well.

Unfortunately I had a hard time confirming whether mapserver
draws the contour lines in that region or not using a standard
client (qgis or udig) as the capabilities document is mis-setup
(points back to a url containing c:/blah/blah/mapfile.map)

Can someone have a look into this? Maybe it's just a problem in
the shptreevis conversion utility having troubles with the large
qix files (the ones I'm using for GeoServer are significantly smaller)


PS: btw, shptreeview is a quite nice utility, thanks for sharing :-)

Andrea Aime
OpenGeo - http://opengeo.org
Expert service straight from the developers.

-------------- next part --------------
A non-text attachment was scrubbed...
Name: indexes-nq8.png
Type: image/png
Size: 17004 bytes
Desc: not available
Url : http://lists.osgeo.org/pipermail/benchmarking/attachments/20100902/9f0b2112/indexes-nq8-0001.png

More information about the Benchmarking mailing list