[OSGeo-Conf] FOSS4G 2008 broken?

Frank Warmerdam warmerdam at pobox.com
Sun Jan 29 16:31:15 EST 2012

On 12-01-29 09:46 AM, Arnulf Christl wrote:
> Folks,
> seems like something broke in the FOSS4G 2008 setup, the links don't
> direct to a working copy of the conference:
> http://foss4g.org/
> goes to:
> http://conference.osgeo.org/index.php/foss4g/2008
> http://2008.foss4g.org/
> goes to:
> http://conference.osgeo.org/index.php/foss4g/foss4g2008


I looked into this briefly.  The 2008 web site was managed using OCS.
OCS is currently living on the webextra VM.  I'm not who migrated it
there from osgeo1, but to the best I can understand it is not working
properly and I don't know why.

I gather the data for the conference live in mysql.


OK, after some more fiddling I found that one of the .php files in
/osgeo/ocs2/ocs-2.1.1-2/cache appeared to be truncated.  Under the
assumption items in a directory called cache were recreateable I
erased all the .php files in this directory.  Magically everything worked
after that.

I'm not sure how things got into this state, but it is working now.

It is my personal opinion that depending on a running instance of
OCS for the 2008 site is very fragile and it would be nice if we could
somehow extract a static web site for that conference with all the
valuable materials.

However, that isn't something I really want to take on.

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam, warmerdam at pobox.com
light and sound - activate the windows | http://home.gdal.org/warmerda
and watch the world go round - Rush    | Geospatial Software Developer

More information about the Conference_dev mailing list