[ELGIS] osm2pgsql-0-0.1.20100821svn_1.el5.elgis.x86_64 from installed has depsolving problems

Mathieu Baudier mbaudier at argeo.org
Fri Aug 19 04:55:11 EDT 2011

On Thu, Aug 18, 2011 at 19:22, Mathieu Baudier <mbaudier at argeo.org> wrote:
>> $ yum repolist
>> Loaded plugins: fastestmirror
>> repo id                     repo
>> name                                                          status
>> base                        CentOS-5 -
>> Base                                                    enabled: 3,535
>> elgis                       EL GIS 5 -
>> x86_64                                                  enabled:    66
>> epel                        Extra Packages for Enterprise Linux 5 -
>> x86_64                     enabled: 6,631
>> extras                      CentOS-5 -
>> Extras                                                  enabled:   299
>> pgdg90                      PostgreSQL 9.0 5 -
>> x86_64                                          enabled:   118
>> updates                     CentOS-5 -
>> Updates                                                 enabled:   765
>> repolist: 11,414
> sorry for not answering sooner.
> The pgdg repositories are not compatible with the ELGIS repository.
> Only the=base postgresql84 is supported.

Please keep the mailing-list cced so that others can benefit from the

The pgdg repositories ship their own version of some base GIS
libraries (geos, etc.), hence the conflicts.

If you really need to use PostgreSQL 9.x, I'm afraid that you will
have to rebuild the source RPMs of the packages you are interested in.
This is not necessarily very complicated but you will need to learn
how to do it (here is a good start:

If you don't want to invest too much time in packaging etc. you will
probably be better using the base PostgreSQL version and the
EPEL/ELGIS packages.

More information about the el mailing list