[El] Did I just make a lot of work for myself or is there an easy way out?

Volker Fröhlich volker27 at gmx.at
Fri Feb 18 20:21:50 EST 2011

Dear Bill!

The packages in EL GIS are often built against other packages, that are likely 
newer than in EPEL.

Usually Yum throw errors on wrong versions of shared libraries and doesn't let 
you install as desired, without also installing these newer packages. To catch 
other version requirements, packages can also contain version restrictions 
that were set manually. Nevertheless, not everything might be covered. That 
must be the case here, I think.

There is a "yum downgrade foo" command. I have never tried it though. It 
should give you back previous versions of packages. Is your machine 64 bit? 
The i386 packages shouldn't harm.

In case you need some of the package versions from EL GIS, but want them built 
against your installed versions of software, you can rebuild these packages on 
your machine. You therefore need the source RPM and developer packages. You 
can then install these packages.

The rebuild is basically:

#Get the build requires
yum-builddep foo.src.rpm

#Build a package using your package versions (if possible)
rpmbuild --rebuild foo.src.rpm

The packages required for that are rpm-build and yum-utils.  You might also 
have to run

yum groupinstall "Development Tools"

I hope that is somewhat helpful.


Am Samstag 19 Februar 2011, 01:19:09 schrieb Bill Thoen:
> Hi Folks,
> Ignorant YUM Newbie here. I wonder if some can tell me if I screwed this
> up and if so how to fix it? I've got the EL GIS 5 and EPEL repos set up
> on my CentOS 5.0 system, and it's been working fine. Apparently I also
> have postgres set up along with CentOS repos.
> To I noticed that I didn't have MapServer so I did a simple-minded
> thing, I just sent YUM off to "install mapserver". Well it seemed to be
> working, but at the end it started spiting out error announcing that
> several support packages were incompatible. It also seemed to have tried
> to install a lot of i386 modules. Obviously, it wasn't a good install,
> and I'm wondering what to do to correct things. Or  do I have to pick
> things apart one module at a time? I'd also like to know what I should
> have done or recognized before I got into this mess. I've attached a log
> of the session so you can see what I saw. Sorry for attaching the whole
> thing, but I don't know what bits are important to diagnose this.

More information about the el mailing list