[El] Problem installing 'rgdal' package under R 2.12.1 and gdal 1.7.3

Mauricio Zambrano mauricio.zambrano at jrc.ec.europa.eu
Wed Feb 23 08:59:40 EST 2011

On Wed, 2011-02-23 at 14:36 +0100, Mathieu Baudier wrote:
> > May I just remove all the files within /usr/local/lib and the
> > directory /usr/local/share/gdal ?
> yes (move them somewhere else)

Fortunately, the problem was solved by moving all the previous files, as
you can see now:

> library(rgdal)
Loading required package: sp
Geospatial Data Abstraction Library extensions to R successfully loaded
Loaded GDAL runtime: GDAL 1.7.3, released 2010/11/10
Path to GDAL shared files: /usr/share/gdal
Loaded PROJ.4 runtime: Rel. 4.7.1, 23 September 2009
Path to PROJ.4 shared files: (autodetected)

> If the problem persists afterwards, maybe you should run ldconfig:
> sudo /sbin/ldconfig -v
> (really no warranty on this one: it may really impact your install
> although this is very unlikely!)

One more time, Thank you very much Mathieu !

All the best,

Linux user #454569 -- Ubuntu user #17469
"We would accomplish many more things 
if we did not think of them as impossible."
(Chretien Malesherbes)

More information about the el mailing list