[fdo-internals] RE: RFC 52 -- Convenience C++ API wrapper for FDO

Konstantin Baumann Konstantin.Baumann at autodesk.com
Mon Aug 9 04:17:37 EDT 2010


Hi Traian,

I like that very much!!

Some minor comments (but note, I haven't looked into your header files yet, just based on the given samples):

* We had a very similar interface in LDX, but using some more smart pointers, that you elegantly removed by your proposal.

* I would propose to use a namespace for the wrapper/library.

* Some method names are not consistent:
	- DbHandle::Count()	suggested: DbHanlde::GetTableCount()
	- Table::GetRowCount()	suggested: keep it as it is
	- RowDef::ColumnCount()	suggested: RowDef::GetColumnCount()

* I would have expected an argument for Table::At(); I would suggest to use Table::At(FID id) for random access queries (do you want to support them, too?) and Table::Current() for the sequential case.

* the samples are missing the returning the connection to the connection pool

* discussion about the "get all fields": there is currently an OGR RFC discussing this issue right now (http://trac.osgeo.org/gdal/wiki/rfc29_desired_fields); something like the proposed solution could probably also be easily incorporated into your proposal, right?

* is there a need for "bulk inserts"? deletion of features? "bulk deletions"?

* the samples do not show the definition of a new schema from scratch (not by copying an existing one, which is already covered) for creating a new database.

Overall I like that very much, and I guess that interface would be way easier to learn and scare a lot less people than the existing one!

Kosta

> -----Original Message-----
> From: fdo-internals-bounces at lists.osgeo.org [mailto:fdo-internals-
> bounces at lists.osgeo.org] On Behalf Of Traian Stanev
> Sent: Monday, August 09, 2010 01:15
> To: 'FDO Internals Mail List'
> Subject: [fdo-internals] RFC 52 -- Convenience C++ API wrapper for FDO
> 
> Hello all,
> 
> As you know, I have recently complained about FDO API complexity [1].
> Complaining is nice and all, but it's better done in C/C++ form, so I have
> posted a proposal for API simplification as FDO RFC 52. The proposal
> includes a working draft implementation.
> 
> If interested, have a look, I'd be interested in comments and suggestions
> for improvement of the design and implementation.
> 
> http://trac.osgeo.org/fdo/wiki/FDORfc52
> 
> Thanks,
> Traian
> 
> 
> [1] http://osgeo-org.1803224.n2.nabble.com/resignation-from-FDO-PSC-
> td5302376.html#a5302376
> 
> _______________________________________________
> fdo-internals mailing list
> fdo-internals at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/fdo-internals


More information about the fdo-internals mailing list