[Gdal-dev] Error 4 problem

Tan Meng Howe tan_meng_howe at yahoo.co.uk
Thu Apr 15 23:00:12 EDT 2004

Hi all,

I was trying out gdal with jasper (both are the latest
version downloadable from gdal website) on windows XP
using VC6. I was able to compile successful. However,
when I tried to use the gdal_translate program to
convert from a tif to a jpeg2000, I got the following

Error 4: 'test.jp2' not recognised as a supported file

I had also tried writing a DLL that call the GDAL DLL.
When I tried to execute my DLL (using a java program
through JNI), I got the same error when I tried to use
the GDALOpen function to load a tif file.

I suspected that I need to tweak some compiler setting
to solve the problem. Have anyone here face this
problem before and manage to solve it? Thanks. 

PS: I am pretty new to VC6 and is not familar with the settings.

Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 

More information about the Gdal-dev mailing list