[Gdal-dev] Error compiling gdal with MrSid support in ubuntu linux

Mikael Schröder miscx at spray.se
Wed Mar 29 06:41:36 EST 2006

I have been trying to add support for MrSid (but also ecw) to the
libgdal1c2(a) package in ubuntu breezy (I have also tried to compile
directly from source).
But I get the following error message:

In file included
from /usr/local/MrSid_GeoExpressSDK/include/support/lt_types.h:28,
                 from mrsiddataset.cpp:117:
error: #error PLATFORM ERROR: Unsupported version of GCC
make[3]: *** [../o/mrsiddataset.o] Error 1
make[3]: Leaving directory
make[2]: *** [mrsid-install-obj] Error 2
make[2]: Leaving directory
make[1]: *** [frmts-target] Error 2
make[1]: Leaving directory `/home/micke/source/gdal_dpkg_t4/gdal-1.2.6'
make: *** [build-stamp] Error 2

I have installed gcc 3.2.3 from Warty and downloaded the corresponding
dsdk from Lizardtech's developer-site. 
Before i run dpkg I execute (as root):
$ export PATH=/usr/bin/gcc-3.2:$PATH CC=/usr/bin/gcc-3.2           
$ PATH=/usr/bin/gcc-3.2:$PATH CC=/usr/bin/gcc-3.2 dpkg-buildpackage -us
-uc -rfakeroot

I have also linked gcc to gcc-3.2 in /usr/bin
What am i doing wrong?

/Regards Mikael
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20060329/7f00746a/attachment.html

More information about the Gdal-dev mailing list