[Gdal-dev] Some issues with GDAL WCS support

Ethan Alpert ealpert at digitalglobe.com
Fri Nov 16 11:59:40 EST 2007

Wow this took over 12 hours to get to the gdal-dev list. Anyhow, I've
tried the
but that does not appear to get applied in the EstablishRasterDetails()



From: gdal-dev-bounces at lists.maptools.org
[mailto:gdal-dev-bounces at lists.maptools.org] On Behalf Of Ethan Alpert
Sent: Thursday, November 15, 2007 4:51 PM
To: gdal-dev at lists.maptools.org
Subject: [Gdal-dev] Some issues with GDAL WCS support




I've looked at both stable and trunk and the problem is the same.
Furthermore, it looks like the WCS server gdal uses to test with does
not provide a complete DescribeCoverage.




Note that <rangeSet> is undefined. 


Anyhow I have a WCS service which does not have a set a default band
identifier so when GDAL tries to do a GetCoverage in
WCSDataset::EstablishRasterDetails() it doesn't provide a band=
parameter resulting in the following service exception:


<ServiceException code="MissingParameterValue" locator="Request does not
include BAND value, and the service instance did not declare any default
value for that parameter. "></ServiceException>



I think GDAL needs to parse the DescribeCoverage and use the rangeSet to
set up the list of bands in the WCS offering.


I did a real quick and dirty test and inserted the band identifiers into
all the GetCoverage url constructions and GDAL worked with my WCS.  Of
course this would be simpler if my WCS had default bands but it doesn't.


Got to catch a bus now but I think this should probably be a bug report.





-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/gdal-dev/attachments/20071116/9da2e8a0/attachment.html

More information about the gdal-dev mailing list