[gdal-dev] gdal 1.5.0 and 1.5.1 build on Solaris 9

Gong, Shawn (Contractor) Shawn.Gong at drdc-rddc.gc.ca
Thu May 29 17:15:06 EDT 2008

hi list,

I have been trying to build gdal 1.5.1 build on Solaris 9 (SPARC, gcc
3.4.6) without success.
The last success build on Solaris 9 is gdal 1.4.4 (done last week). 
However when I used the exactly same setenv PATH, LD_LIBRARY_PATH and
LDFLAGS="-lrt -lm -lnsl" on gdal 1.5.0 and 1.5.1, there were erros.

The main reason for the newer gdal is that our Convair 580 PolSAR data
is quite large. It causes gdal I/O problem on Solaris 9 (but ok on Linux
and Windows). I was told that gdal 1.5.1 has fixed this problem. Would
someone please confirm this, otherwise I don't have to spend time on
building it.

gdal 1.5.0 "make" and "make install" seemed finished fine. But unlike
1.4.4 or 1.5.1 there is no .libs/ created under gdal-1.5.0/pymod, and
there is no "_gdalmudule.*" in
[install_dir]/lib/python2.3/site-packages/ As results, "import gdal"
failed right away.
I attached the gmake.log and gmakeinstall.log for gdal 1.5.0.

A gdal 1.5.1, please see the previous email below.
"tiff_driver.CreateCopy( fname, vrtds, ..." causes bus error - core dump

thanks for your help,

-----Original Message-----
From: gdal-dev-bounces at lists.osgeo.org
[mailto:gdal-dev-bounces at lists.osgeo.org] On Behalf Of Gong, Shawn
Sent: Wednesday, May 21, 2008 1:17 PM
To: gdal-dev at lists.osgeo.org
Subject: [gdal-dev] gdal 1.5.1 Bus Error - core dump on Solaris 9

hi list,

I have been using gdal 1.4, and have recently built gdal 1.5.1 for its
large image support.
Gdal 1.5.1 and OpenEV 1.8 building was fine. Then I encounter Bus Error
- core dump on Solaris 9.
I have tracked it down to where the Bus Error occurred:
  gtiff_driver = gdal.GetDriverByName( 'GTiff' )
  self.new_ds = gtiff_driver.CreateCopy( fname, vrtds, ...
A "core" file is generated and kept growing to near half GB.

I have followed Frank's advices of using -fPIC during compiling, and
rebuilt Gdal 1.5.1 from scratch. But I still get the same error.

Help is appreciated,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: make.zip
Type: application/x-zip-compressed
Size: 35338 bytes
Desc: make.zip
Url : http://lists.osgeo.org/pipermail/gdal-dev/attachments/20080529/e87d179b/make-0001.bin

More information about the gdal-dev mailing list