<div dir="ltr"><div dir="ltr"><div dir="ltr">std::unique_ptr<Geometry> ?</div><div dir="ltr"><br></div><div>We've got a mishmash in the code base, what should it be?</div><div>As a learner arriving at the code base, std::unique_ptr<Geometry> would have been easier, since then the semantics of the thing are more immediately transparent then. After working with it for a while, that's less of an issue because I've internalized the fact that GeometryPtr is a std::unique_ptr, but still. </div><div><br></div><div>The best code styleguide is a consistent code base, so deciding and then globally changing makes the most sense, IMO.</div><div><br></div><div>P.</div></div></div>