[GRASS-dev] Re: [GRASS GIS] #979: WxGUI fails to display vector attribute table

GRASS GIS trac at osgeo.org
Tue Mar 9 08:04:28 EST 2010

#979: WxGUI fails to display vector attribute table
  Reporter:  marisn           |       Owner:  grass-dev at lists.osgeo.org
      Type:  defect           |      Status:  new                      
  Priority:  critical         |   Milestone:  6.4.0                    
 Component:  wxGUI            |     Version:  svn-releasebranch64      
Resolution:                   |    Keywords:  wxgui, wingrass, database
  Platform:  MSWindows Vista  |         Cpu:  x86-32                   
Comment (by hamish):

 Replying to [comment:5 marisn]:
 > http://www.gisnet.lv/ggmlinux/grass_01.avi

 pop up window at the start of it:
 __Attribute table manager error__

 (X) Unable to determine default DB connection settings. Please define DB
 connection using db.connect module.

 that error comes from gui/wxpython/gui_modules/dbm.py after running
 `db.connect -p` if driver: or database: has no value.

 What does `db.connect -p` say from the MSys command line? (or from the
 Cmd> prompt)

 does the drosmins mapset have a valid VAR file in it?
 (we are reading a vector+table from another mapset in this example, so I'm
 not sure how useful what db.connect tells us is going to be, but...)

 do you see the same error if you g.copy the vector into the current mapset

 following the same actions work for me in Windows XP.


 ps- your English is really fine, the problem is that there are twenty ways
 for the common commands to be called as part of different work-flow areas,
 so knowing which one it is takes a lot of describing. the video was super
 clear, thanks.

Ticket URL: <https://trac.osgeo.org/grass/ticket/979#comment:8>
GRASS GIS <http://grass.osgeo.org>

More information about the grass-dev mailing list