[GRASS-dev] Re: name of nviz_cmd module

Hamish hamish_b at yahoo.com
Sun Aug 21 07:24:55 EDT 2011

> > I have a question concerning nviz_cmd. Martin supposed
> > the module's name to be just temporary. Do you feel that
> > nviz_cmd name should be replaced? Any suggestions?

> right see [1] for details.
> [1] http://lists.osgeo.org/pipermail/grass-dev/2008-December/041160.html
> `d.3d` sounds good for me, I would suggest `d.out.3d`
> because it writes output directly to the file, or
> `d.out.nviz`...

Since this is also in grass 6.x, I worry a little that d.out.* is
too closely tied to the display monitor usage of the other d.*
modules and especially confusion with what d.out.file and
d.out.png do. i.e. nviz_cmd is more a generator than an exporter,
closer in a way to the old p.* paint commands.

also while we are here we should consider the future of d.nviz,
as it is a rather generic name once other options exist too.
I assume that d.nviz in grass 7 will one day be a front-end to
nviz_cmd, with the end-points, vector track, spline fitting, and
time step magic for individual frames performed in d.nviz, and
the actual rendering of each frame done by nviz_cmd in a series
of individual system calls (which could be done in parallel).

maybe d.nviz could call the encoder too? or maybe it would be
cleaner to have a d.3d.movie script around d.nviz and nviz_cmd
for that.

are thoughts about keyframe animation support for wxNVIZ?


d.nviz -> d.nviz.script
nviz_cmd -> d.nviz.image


More information about the grass-dev mailing list