[GRASS-user] r.texture NULL value error

Hufkens Koen koen.hufkens at ua.ac.be
Mon Nov 24 08:39:09 EST 2008

Hi list,

I've been trying to run a r.texture filter on a map but I constantly get the error:

ERROR: Negative or no data pixel found. This module is not yet able to
       process no data holes in a map, please fill with r.fillnulls or
       other algorithms

However, I ran r.null to set all NULL values to 0 and r.categories also showed no negative values afterwards.

What could be the cause of this error.

I also rescaled the categories between 0 and 100.

After all this the ERROR is still their. 

Furthermore, If I run a 3x3 r.neighbourhood average moving window analysis on this map, r.texture runs fine on the result of r.neighbourhood.

I really don't know what causes this inconsistent behaviour. Any ideas what causes this error?

Kind regards,
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20081124/b65ef1bb/attachment.html

More information about the grass-user mailing list