[GRASS-user] r.series g.mlist unhappy together

saewan koh saewan at gmail.com
Wed May 20 14:51:23 EDT 2009

Hi Markus and Daniel,

Thanks for checking into this.  I am currently going thru the nabble  
archives to see if there are issues with os x and g.mlist.  I am going  
to install GRASS6.3 on my other computer and see if my problem is  
specific to my current set up.

Can anyone suggest a work around in the event I can't get r.series to  
work with g.mlist?  Is there a way I can use the two separately?

The last weird thing i just discovered is that when i use g.mlist on  
its own  - it will not run if i use quotations as in g.mlist rast  
It does run if i use g.mlist rast pat=SmrDDT0Tot*
So i wonder if my issue is something in the way the script is running  
within the shell.

Anyway ff there is anyone running GRASS 6.4.ORC4 on Mac OS X v.  
10.5.6  who wouldn't mind trying r.series with g.mlist please let me  
know if you can get it to work.

Thanks again,


On 20-May-09, at 2:37 AM, Markus Neteler wrote:

> On Wed, May 20, 2009 at 3:37 AM, Daniel Victoria
> <daniel.victoria at gmail.com> wrote:
>> What is the exact command line you used and the error message?  
>> Because
>> in your first email the error was due to the wrong use of quotes.
> Not sure about this statement ... FWIW for me:
> GRASS 6.4.0svn (spearfish60):~ > r.series input="`g.mlist pat='road*'
> sep=,`" output=test1987dd0 method=sum
> Reading raster map <roads>...
> 100%
> works perfectly on a Linux box.
> Markus

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/grass-user/attachments/20090520/76abe00b/attachment-0001.html

More information about the grass-user mailing list