[GRASS-windows] Command line problems

Hanlie Pretorius hanlie.pretorius at gmail.com
Wed May 19 05:47:36 EDT 2010

The batch file didn't work, got an error 'Windows cannot find
f:\Program'. Wasn't sure what to do with the first line (set
HOME=%HOMEDRIVE%%HOMEPATH%), so just used it as is in the batch file.

I did get the GRASS with MSYS menu option to work by adding the paths
to sh.exe and MinGW to my PATH environment variable and the eval 'cat
r.in.xyz...' command works now.

Thanks for the help.

2010/5/18, Glynn Clements <glynn at gclements.plus.com>:
> Hanlie Pretorius wrote:
>> I seem to have msys installed with my GRASS installation, but it doesn't
>> work.
>> When I try to run GRASS with MSYS from the menu, it can't find
>> rxvt.exe or sh.exe.
>> I found sh.exe in the msys\bin folder of my GRASS installation and I
>> can run it from there, but I can't use it for anything. If I run the
>> shell and enter:
>> eval `cat VTL2733.XYZ | r.in.xyz -s -g in=- fs=space out=test`
>> I get the error messages:
>> cat: command not found
>> r.in.xyz: command not found
> This is due to the PATH setting.
> If you start MSys via the msys.bat it will set PATH, but it will also
> run in an rxvt Window, which is rather unreliable.
> I suggest creating a batch file, e.g.:
> 	set PATH=C:\msys\1.0\bin;C:\MinGW\bin;%PATH%
> 	start C:\msys\1.0\bin\sh.exe
> Change the paths as appropriate for your system.
> That will start a shell in a command window. From there, you will need
> to start GRASS before you can use any GRASS commands.
> --
> Glynn Clements <glynn at gclements.plus.com>

More information about the grass-windows mailing list