[Liblas-devel] CMake working for current source?

Howard Butler hobu.inc at gmail.com
Sat Apr 17 14:36:59 EDT 2010

On Apr 16, 2010, at 1:09 PM, Dan Bellinski wrote:

> I am running CMake on 64 bit Windows and CMake is not able to find the
> ST_CREATE function for libGeoTiff. CMake is returning the error (this error
> is present in a self-compiled version of libGT 1.3 as well as the 1.2.5
> libgeotiff installed from OSGeo4w):
> Searching for GeoTIFF 1.2.5+ library
> Trying OSGeo4W using default location OSGEO4W_ROOT=c:/OSGeo4W
> Found GeoTIFF version: 1.3.0
> CMake Error at CMakeLists.txt:155 (message):
>  GeoTIFF support requires libgeotiff 1.2.5 or newer.
> which is being thrown in CMakeLists.txt at:
>            set(GEOTIFF_FOUND) # Reset to NOT found for GeoTIFF
>            message(FATAL_ERROR "GeoTIFF support requires libgeotiff 1.2.5
> or newer.")
> ...I tried to just comment that out but my compiled .exes just throw
> run-time errors so I am guessing that won't work. Could it be this isn't
> compatible with 64bit?

The 1.2.5 in OSGeo4W is most likely not 64bit, and is it possible that it's finding that when it is doing a test link due to directory ordering before finding your 64bit self-compiled version?  Does libgeotiff have switches in its makefile.vc for 64bit compilation?  (I don't have 64bit windows to test and have never tried it).

More information about the Liblas-devel mailing list