[Liblas-devel] Proposal to rename C++ Class Names

Howard Butler hobu.inc at gmail.com
Sun Feb 7 22:37:06 EST 2010


All,

I have been undertaking an effort to refactor the internal reader and writer implementations of the C++ code, and one thing I've noticed is the complete redundancy of the class names.  For example, we have:

LASPoint
LASReader
LASWriter
LASHeader
LASSpatialReference
...

but in reality, because of C++ namespacing, these are:

liblas::LASPoint
liblas::LASReader
liblas::LASWriter
liblas::LASHeader
liblas::LASSpatialReference

"LAS" is totally redundant in the class names and especially the include and src file names (lasspatialreference.hpp lasspatialreference.cpp, etc).  I would like to simplify them to:

liblas::Point
liblas::Reader
liblas::Writer
liblas::Header
liblas::SpatialReference

I would propose that we also provide a <liblas/compatibility.hpp> include file that would provide typedef's back to the old names so that a user could use new C++ code by conditionally including the compatibility file without too much disruption. 

Though I don't know for sure, I think that our renaming the C++ class names at this point shouldn't be too disruptive, and I would like to hear back from libLAS developer users on the subject.  This refactoring would have no impact on the C or Python APIs (the writer/reader refactoring will not have any either).  Any objections?

Howard



More information about the Liblas-devel mailing list