[mapguide-users] Can't insert feature into certain SDFs

Takashige Nakagawa ta-nakagawa at apptec.co.jp
Wed May 16 08:27:00 EDT 2007

Hi all.

I've been testing my code which insert features into SDFs and it worked well 
so far.
When it comes to certain SDFs, however, it wouldn't work.
I can delete and update features of these SDFs, so "Read Only" issue seems 
not to have anything with this problem.

All properties are nullable except one described below.

<xs:element name="FeatId">
<xs:restriction base="fdo:int32" />

This is the key field to the feature. I assume the case of this problem is 
that this field value is not "auto-generated",
because when the key field is like :

<xs:element name="Autogenerated_SDF_ID" fdo:readOnly="true" minOccurs="0" 
<xs:restriction base="fdo:int32" />
<xs:documentation>Autogenerated identity property</xs:documentation>

I tried to set the key field into "auto-generated" by 
"MgDataPropertyDefinition::SetAutoGeneration() " method, but I couldn't make 
it so.

Does anyone know how to solve this problem?

Any information is appliciated.
Thanks in advance.



More information about the mapguide-users mailing list