[Mapserver-users] WMS requests.

Bob Basques bob.basques at ci.stpaul.mn.us
Mon Apr 5 18:05:03 EDT 2004


Swaminathan, Gayathri wrote:

Somebody holler if this is not on topic for MapServer . . . .

Some more investigating, using the Java Message console in ArcExplorer:

upon hitting OK for connection to my WMS server:

GetCapabilities Request : 
http://pwultra5.ci.stpaul.mn.us/cp_tiles/temp/mapserv.getCapabilities.php?SERVICENAME=pw&VERSION=1.1.1&WMTVER=1.1.1&SERVICE=WMS&REQUEST=capabilities

GetCapabilities Request : 
http://pwultra5.ci.stpaul.mn.us/cp_tiles/temp/mapserv.getCapabilities.php?SERVICENAME=pw&VERSION=1.1.1&WMTVER=1.1.1&SERVICE=WMS&REQUEST=capabilities

###### Start to WMS getCapabilities in GetWMSService class version=null

************** realVersion is = 1.1.0

************** Version is = null


I'm at a loss as to why I need to set things to 1.1.0 . . . .   
Everything else is using 1.1.1 (which doesn't work either BTW), but I'm 
still at a loss as to why 1.1.1 shouldn't work.

bobb


>Bob,
>
>I would rather do the following to get the interoperability working with
>ArcExplorer...(Am gonna list all the steps for your quick reference :)
>
>
>1) Get the Interoperability extension for ArcExplorer -Java Edition
>version 4.0.1 I think.
>
>2) Install that.
>
>3) Get Capabilities using,
>
>http://dragonslayer.ci.stpaul.mn.us/cgi-bin/mapserv?map=<mappath>&VERSIO
>N=1.1.1&REQUEST=Getcapabilities
>
>This should pop you a XML file (does not have .xml extension but, that's
>ok)- Save that to disk
>
>4) Do this at the beginning of the document.
>
><?php
>    header("Content-type:application/vnd.ogc.gml");
>    ?>
>    <WMT_MS_Capabilities version="1.1.1" updatesequence="0">=====> (This
>line is already in your capabilities file you downloaded in step 3, you
>will have   
>	
>to change the version from 1.1.0 to 1.1.1, that is all)
>
>5) Save file as <something>.php under your local intranet site for
>example, could be 
>
>http://dragonslayer.ci.stpaul.mn.us/pws.php
>
>6) Open up ArcExplorer->Interoperability(Menu)->Connect to WMS, type in
>the URL of the .php file, For example,
>http://dragonslayer.ci.stpaul.mn.us/pws.php
>
>Hit OK!
>
>And you should get the layers.
>
>HTH. Let me know if you are running into issues.
>Gayathri
>
>
>
>
>
>  
>
>>-----Original Message-----
>>From: Bob Basques [mailto:bob.basques at ci.stpaul.mn.us] 
>>Sent: Monday, April 05, 2004 4:14 PM
>>To: Swaminathan, Gayathri
>>Subject: Re: [Mapserver-users] WMS requests.
>>
>>
>>Swaminathan, Gayathri wrote:
>>
>>    
>>
>>>No problem,
>>>
>>>On the ArcExplorer...use the hints from here...
>>>
>>>http://mapserver.gis.umn.edu/cgi-bin/wiki.pl?WMSMapserverArcExplorer
>>>
>>>They are helpful
>>> 
>>>
>>>      
>>>
>>I just read in detail, the Message console is a slick troubleshooter,
>>
>>Any idea about what this output might mean related to 
>>connecting to my 
>>service?
>>
>>GetCapabilities Request : 
>>http://dragonslayer.ci.stpaul.mn.us/cgi-bin/mapserv?SERVICENAM
>>E=pw&VERSION=1.1.1&WMTVER=1.1.1&SERVICE=WMS&REQUEST=capabilities
>>
>>GetCapabilities Request : 
>>http://dragonslayer.ci.stpaul.mn.us/cgi-bin/mapserv?SERVICENAM
>>E=pw&VERSION=1.1.1&WMTVER=1.1.1&SERVICE=WMS&REQUEST=capabilities
>>
>>###### Start to WMS getCapabilities in GetWMSService class 
>>version=null
>>
>>************** realVersion is = none
>>
>>************** Version is = null
>>
>>This version is not supported
>>
>>******** Exception for WMS:null
>>
>>java.lang.NullPointerException
>>
>>    at com.esri.ogc.client.WMSServer.refresh(WMSServer.java:236)
>>
>>    at com.esri.ogc.client.WMSServer.<init>(WMSServer.java:67)
>>
>>    at com.esri.ogc.client.WMSServer.getLayerSource(WMSServer.java:48)
>>
>>    at com.esri.ogc.client.WMSUtil.AddWMSLayer(WMSUtil.java:306)
>>
>>    at 
>>com.esri.ogc.viewer.extensions.WMSConnectionDialog.jButton_OK_
>>actionPerformed(WMSConnectionDialog.java:164)
>>
>>    at 
>>com.esri.ogc.viewer.extensions.WMSConnectionDialog$1.actionPer
>>formed(WMSConnectionDialog.java:74)
>>
>>    at javax.swing.AbstractButton.fireActionPerformed(Unknown Source)
>>
>>    at 
>>javax.swing.AbstractButton$ForwardActionEvents.actionPerformed
>>(Unknown 
>>Source)
>>
>>    at 
>>javax.swing.DefaultButtonModel.fireActionPerformed(Unknown Source)
>>
>>    at javax.swing.DefaultButtonModel.setPressed(Unknown Source)
>>
>>    at 
>>javax.swing.plaf.basic.BasicButtonListener.mouseReleased(Unknown 
>>Source)
>>
>>    at java.awt.Component.processMouseEvent(Unknown Source)
>>
>>    at java.awt.Component.processEvent(Unknown Source)
>>
>>    at java.awt.Container.processEvent(Unknown Source)
>>
>>    at java.awt.Component.dispatchEventImpl(Unknown Source)
>>
>>    at java.awt.Container.dispatchEventImpl(Unknown Source)
>>
>>    at java.awt.Component.dispatchEvent(Unknown Source)
>>
>>    at 
>>java.awt.LightweightDispatcher.retargetMouseEvent(Unknown Source)
>>
>>    at 
>>java.awt.LightweightDispatcher.processMouseEvent(Unknown Source)
>>
>>    at java.awt.LightweightDispatcher.dispatchEvent(Unknown Source)
>>
>>    at java.awt.Container.dispatchEventImpl(Unknown Source)
>>
>>    at java.awt.Window.dispatchEventImpl(Unknown Source)
>>
>>    at java.awt.Component.dispatchEvent(Unknown Source)
>>
>>    at java.awt.EventQueue.dispatchEvent(Unknown Source)
>>
>>    at 
>>java.awt.EventDispatchThread.pumpOneEventForHierarchy(Unknown Source)
>>
>>    at 
>>java.awt.EventDispatchThread.pumpEventsForHierarchy(Unknown Source)
>>
>>    at java.awt.EventDispatchThread.pumpEvents(Unknown Source)
>>
>>    at java.awt.EventDispatchThread.run(Unknown Source)
>>
>>
>>    
>>
>>>Gayathri
>>>
>>> 
>>>
>>>      
>>>
>>>>-----Original Message-----
>>>>From: Bob Basques [mailto:bob.basques at ci.stpaul.mn.us]
>>>>Sent: Monday, April 05, 2004 3:45 PM
>>>>To: Swaminathan, Gayathri
>>>>Subject: Re: [Mapserver-users] WMS requests.
>>>>
>>>>
>>>>Swaminathan, Gayathri wrote:
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>>>>Mea Culpa!
>>>>>
>>>>>Should be Layers=L5.
>>>>>That should work.
>>>>>
>>>>>
>>>>>
>>>>>     
>>>>>
>>>>>          
>>>>>
>>>>Geez, I tried every combination but that one! I eve through
>>>>the "s" on 
>>>>the end a couple of times.  It Worked!!
>>>>
>>>>Now to figure out the interoperability extension for ArcExplorer.
>>>>
>>>>
>>>>Thanks (A lot!!) for the help here.
>>>>
>>>>bobb
>>>>
>>>>
>>>>   
>>>>
>>>>        
>>>>
>>> 
>>>
>>>      
>>>
>>    
>>
>
>  
>




More information about the mapserver-users mailing list