Windows XP Installation - How to Debug?

Ed McNierney ed at TOPOZONE.COM
Mon Oct 17 10:08:20 EDT 2005

And for some reason an incorrectly installed/missing ZLIB.DLL seems to
usually be the culprit....

	- Ed

Ed McNierney
President and Chief Mapmaker / Maps a la carte, Inc.
73 Princeton Street, Suite 305
North Chelmsford, MA  01863
ed at
(978) 251-4242  

-----Original Message-----
From: UMN MapServer Users List [mailto:MAPSERVER-USERS at LISTS.UMN.EDU] On
Behalf Of Ken Lord
Sent: Sunday, October 16, 2005 11:53 PM
Subject: Re: [UMN_MAPSERVER-USERS] Windows XP Installation - How to

Hi Kirby,

That error is usually a DLL problem.

at the command line, run mapserver  ...  C:\..\..\mapserv.exe

If there are any missing dll's,  it will tell you. If it does not, then
restart your computer.  WinXP Pro SP2 seems to be a little more fussy
than older versions.

Restarting after a fresh install has fixed that problem for me a couple

If that doesnt help, then use the version of MapServer from

Ken Lord
Vancouver BC

On 10/16/05, Kirby James <kirby at> wrote:
> Hi,
> I've tried to install Mapserver on Windows XP SP2 using the IIS
> When I interrogate Mapserver using 
> http://my_machine/Scripts/mapserv.exe
> I get a web page containing the message "No query information to
> QUERY_STRING not set." Which I guess implies that much of the 
> configuration is OK.
> I've tried to install the Itasca example - I can correctly see the 
> index page "http://my_machine/mapserver/workshop/index.html" but when 
> I "Initialize" the "Basic Application" option (which delivers a URL of

> http://my_machine/Scripts/mapserv.exe?layer=lakespy2&layer=dlgstln2&zo
> omsize=2&
> program=%2FInetpub%2FScripts%2Fmapserv.exe&root=%2FInetpub%2Fwwwroot%2
> Fmapserver%2Fworkshop&map_web_imagepath=%2FInetpub%2Fwwwroot%2Fmapserv
> er%2Fworkshop%2Ftmp&map_web_imageurl=mapserver%2Fworkshop%2Ftmp&map_we
> b_template=itasca_basic.html
> I get the response "CGI Error - The specified CGI application 
> misbehaved by not returning a complete set of HTTP headers. The 
> headers it did return are:" - with no text following.
> I've tried various combinations of paths in the MAP file (latest 
> version shown below) - but keep getting the same result.
> I'd appreciate any suggestions as to how I can identify the cause of 
> the problem,
> Regards
> Kirby
>  WEB
>   HEADER templates/header.html
>   TEMPLATE "set in index.html"
>   FOOTER templates/footer.html
>   MINSCALE 1000
>   MAXSCALE 1550000
>   IMAGEPATH "set in index.html"
>   IMAGEURL "set in index.html"
>     WMS_TITLE "UMN MapServer Itasca Demo"
>     WMS_ABSTRACT "This is a UMN MapServer application for Itasca 
> County located in north central Minnesota."
>     # change this value to match your setup
>     WMS_SRS "EPSG:26915"
>   END
>  END

More information about the mapserver-users mailing list