[mapserver-users] msWMSFeatureInfo(): Unsupported INFO_FORMAT value (text/html).

Ir. Peter Huis in 't Veld peterh at ivs90.nl
Mon Nov 23 10:11:01 EST 2009

Hi Daniel,

Correct I did place the wms_feature_info_mime_type at the wrong level.

Problem solved I would say.



Daniel Morissette schreef:
> The "wms_feature_info_mime_type" metadata should be at the map/web level.
> You'll also need different templates for the HEADER, TEMPLATE and 
> FOOTER for your layers since all three serve a different purpose.
> BTW, there was a thread about a similar issue on the openlayers-users 
> list on Friday, you should probably have a look:
> http://openlayers.org/pipermail/users/2009-November/015037.html
> Daniel
> Peter Huis in 't Veld wrote:
>> Hi,
>> Using Mapserver for serving as a WMS I hav:e the following problem:
>> When I change the info_format to text/plain the ouput looks fine but 
>> in case of text/html I get the following message:
>>    msWMSFeatureInfo(): WMS server error. Unsupported INFO_FORMAT 
>> value (text/html).
>> Within my map file I've defined  at Layer level:
>> "wms_title"
>> "wms_feature_info_mime_type" "text/html"
>> "ows_feature_info_mime_type" "text/html"
>> "wms_include_items" "text/html"
>> HEADER  '/var/www/html/template.html'
>> TEMPLATE '/var/www/html/template.html'
>> FOOTER '/var/www/html/template.html'
>> Did I forget something or can I force the request from the client 
>> (Openlayers) in such way it changes the info_format as part of  the 
>> request to "text/plain"?
>> thanks for any support
>> Peter
>> _______________________________________________
>> mapserver-users mailing list
>> mapserver-users at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/mapserver-users

-------------- next part --------------
A non-text attachment was scrubbed...
Name: peterh.vcf
Type: text/x-vcard
Size: 309 bytes
Desc: not available
Url : http://lists.osgeo.org/pipermail/mapserver-users/attachments/20091123/649efea9/peterh.vcf

More information about the mapserver-users mailing list