[mapserver-users] SQL Server 2008 and WFS Service

Tamas Szekeres szekerest at gmail.com
Sat Jul 24 17:25:43 EDT 2010

2010/7/24 geographika <geographika at gmail.com>

> Has anyone successfully created a WFS service using the SQL Server 2008
> plug in?
> I followed the steps at http://mapserver.org/ogc/wfs_server.html, and get
> no errors when running a SERVICE=WFS&VERSION=1.0.0&REQUEST=getcapabilities
> request.
> However when trying to retrieve the features using a feature request
> (&SERVICE=WFS&VERSION=1.0.0&REQUEST=getfeature&TYPENAME=RoadsWFS) I don't
> get any GML. There are no errors in the MapServer log file. I don't believe
> this GET request requires a proxy and I get the same result on the server
> itself.
> I ran SQL Server profiler and the results and geometry are being correctly
> queried from the database. A shortened version of the SQL is below (several
> attributes removed):
> SELECT convert(varchar(max), RoadID),GEOM.STAsBinary(),convert(varchar(20),
> ROADID) from RoadNetwork2 WHERE
> GEOM.STIntersects(Geometry::STGeomFromText('POLYGON((-710069 7038976,-683731
> 7038976,-683731 7059350,-710069 7059350,-710069 7038976))',3785)) = 1
> I think there may be an issue due to none of the columns having names.


I've just tried with the recent version of the mssql2008 driver and it works
for me. Which mapserver version are you testing with?
I would recommend to do a test with one of the daily build packages from:

If your problem still persists, feel free to open a ticket, attach your
mapfile, sample requests and test data (ie. a shapefile) to be uploaded to
the mssql2008 server.

Best regards,

-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapserver-users/attachments/20100724/49ae946f/attachment.html

More information about the mapserver-users mailing list