[mapserver-users] MapServer as WMS client - HTTPS CERTIFICATE problem.

Bob Basques Bob.Basques at ci.stpaul.mn.us
Tue Aug 2 17:35:37 EDT 2011


Ok, got the debugging to spit out the actual request for a service, with the following CERT error :: 

[Tue Aug  2 16:21:59 2011].998742 CGI Request 1 on process 14407 
[Tue Aug  2 16:22:00 2011].23599 msHTTPExecuteRequests(): HTTP request error. HTTP: request failed with curl error code 60 (SSL certificate problem, ve 
rify that the CA cert is OK. Details: 
error:14090086:SSL routines:func(144):reason(134)) for https://xxx.xx.xxxxxx.xx/ArcGIS/services/StPaul/ParcelPolyWMSF/MapServer/WMSServer?LAYERS=0& 
[Tue Aug  2 16:22:00 2011].23974 msDrawWMSLayerLow(): WMS server error. WMS GetMap request failed for layer 'Parcel Polygons' (Status -60: SSL certific 
ate problem, verify that the CA cert is OK. Details: 
error:14090086:SSL routines:func(144):reason(134)). 
[Tue Aug  2 16:22:00 2011].23989 msDrawMap(): Layer 1 (Parcel Polygons), 0.000s 
[Tue Aug  2 16:22:00 2011].24013 msDrawMap(): Drawing Label Cache, 0.000s 
[Tue Aug  2 16:22:00 2011].24026 msDrawMap() total time: 0.025s 
[Tue Aug  2 16:22:00 2011].77595 msSaveImage() total time: 0.053s 
[Tue Aug  2 16:22:00 2011].77691 mapserv request processing time (loadmap not incl.): 0.079s 
[Tue Aug  2 16:22:00 2011].77701 msFreeMap(): freeing map at 0x7144b0. 

Question, can this be handled in the MAPFILE somehow?  I did verify that the request works, once it's sent, by pasting into a Browser that already accepted the certificate. 



-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/mapserver-users/attachments/20110802/3309b9a2/attachment.html

More information about the mapserver-users mailing list