<div><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">&gt;<br> &gt; After some investigations, I found how to fix it.<br> &gt;<br> &gt; I&#39;ve changed the piece of the code where it calculates the coordinates,<br>
 &gt; from:<br> &gt;<br> &gt;&nbsp;&nbsp; var lonlat = map.getLonLatFromLayerPx(evt.xy);<br> &gt;<br> &gt; To:<br> &gt;<br> &gt;&nbsp;&nbsp; var lonlat = map.getLonLatFromViewPortPx(evt.xy);<br> &gt;<br> &gt; Now it works fine.<br> &gt;<br> &gt; I&#39;m just wondering, what&#39;s the difference of &quot;getLonLatFromLayerPx&quot;, and<br>
 &gt; &quot;getLonLatFromViewPortPx&quot;? I&#39;ve looked at the docs but I still don&#39;t get it.<br> &gt; At first glance, I thought that these methods were similars.<br> <br> The answer is actually: &quot;THey&#39;re the same insofar as you shouldn&#39;t need<br>
 to use either one of them&quot; :)</blockquote><div><br><br>Thanks! I knew I was missing something! =)<br>&nbsp;</div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
 Both of these are really designed to be internal methods: I&#39;ve just<br> changed their definition from APIMethod to Method. The one you *shoul*<br> be using is the more nicely named getLonLatFromPixel: this hides the<br>
 fact that you have to worry about any of this stuff.</blockquote><div><br><br>Good. I think this will help other users looking for some info about this in<br>the documentation.<br>&nbsp;<br></div><br><blockquote class="gmail_quote" style="border-left: 1px solid rgb(204, 204, 204); margin: 0pt 0pt 0pt 0.8ex; padding-left: 1ex;">
 In any case: We providedd getLonLatFromPixel as the main &#39;API&#39; property<br> so that people wouldn&#39;t have to use a funky-named property: it&#39;s a<br> wrapper around getLonLatFromViewPortPx.<br> </blockquote>
</div><br>Just a suggestion. Considering that the &quot;getLonLatFromPixel &quot; is a <br>wrapper around &quot;getLonLatFromViewPortPx&quot;, why not renaming it as<br>&quot;getLonLatFromPixel&quot;, and use this in the rest of the library?<br>
<br>As JavaScript is a interpreted language, all function calls has a cost,<br>and because of this, is not recommended to use wrappers and getters <br>since they will just call another function, with a higher performance cost.<br>
<br>But, of course, changing this will require a refactoring and many files,<br>so one have to analyze well the benefits of making such a change,<br>before starting the refactoring.<br><br>Thanks for the helpfull answer!<br>
<br><br>my best regards,<br><br>Pedro Simonetti.<br>