[postgis-devel] What should be the minimum PostgreSQL version for 1.5

Paragon Corporation lr at pcorp.us
Sat Aug 8 23:44:19 PDT 2009

What should be the minimum required version for PostGIS 1.5?

I'm thinking we should bump this up to PostgreSQL 8.3 for the following

1) We are introducing typmod for geography which will only be supported for
PostgreSQL 8.3+
2) We really need to put costs in our functions, as I have updated Nicklas's
bug ticket to reflect. http://trac.osgeo.org/postgis/ticket/230
 Yes we can conditionally put in 

logic to build costs in for 8.3 and leave them out for lower versions and
yes its not that much code, but should we go for simplicity instead so we
don't have to take it out when we move to PostGIS 2.0?

3) I believe Steve Frost mentioned his new tiger requires 8.3+ at least for
loading the data, not necessarily for using the functions.
4) One less platform to test on and build for (except for bug fixes to older
versions).  Besides the whole pgxs thing I think changed between 8.2 to 8.3
which makes 8.2 more annoying to build for.
5) The fact that I can do a set search_path on ST_Transform to get around my
annoying problem my ST_Transform indexes not coming back after restore. Once
we move to named schemas, this will probably become more important to
specify search paths for our functions.


I suspect we do have a lot of users still running on 8.2, though hopefully
that is quickly decreasing.  I suspect its probably under 20% of our
population (but not sure how much higher or lower it is than that)

Of course we should look at the matrix to see how big of a pain 8.2 really


More information about the postgis-devel mailing list