[postgis-devel] WKT Raster: Why having to compile PostgreSQL&PostGIS first?

Pierre Racine Pierre.Racine at sbf.ulaval.ca
Mon Mar 2 07:33:47 PST 2009

>> ---------------------------------------------------------------
>> make[4]: Entering directory
>> `/wktrasterdevel/postgresql-8.3.5/src/backend/access/common' gcc -O2
>> -Wall -Wmissing-prototypes -Wpointer-arith -Winline
>> -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing
>> -fwrapv -I../../../../src/include -I./src/include/port/win32
>> -DEXEC_BACKEND  "-I../../../../src/include/port/win32" -DBUILDING_DLL
>>  -c -o printtup.o printtup.c In file included from
>>  from ../../../../src/include/libpq/libpq-be.h:50, from
>> ../../../../src/include/libpq/libpq.h:21, from printtup.c:19:
>> c:/mingw/bin/../lib/gcc/mingw32/3.4.5/../../../../include/sspi.h:60:
>> error: syntax error before "SECURITY_STRING"
>Googling for the error message confirms this is a known bug and small
>fix is explained here:

Thanks. However if I can live with a released version of PostgreSQL,
I'll be happy.

>> So following your suggestion that "There is no need to build
>> PostgreSQL" I installed 8.3.6...
>> Can I compile Geos with gcc? Or I have to use VC?
>GEOS can be build with both. However, I have no idea if you can safely
>mix binaries built with MinGW and Visual C++.
>> ./configure doesn't seems to be an option.

racinep at DESROCHERSA-02 /wktrasterdevel/geos/trunk
$ ./configure
sh: ./configure: No such file or directory

racinep at DESROCHERSA-02 /wktrasterdevel/geos/trunk
$ autogen

Autogen hang without doing anything...


More information about the postgis-devel mailing list