[postgis-devel] Error compiling r4906: POSTGIS_LIBXML2_VERSION

Jorge Arévalo jorge.arevalo at gmail.com
Thu Nov 26 10:08:21 PST 2009


Hello,

I'm compiling PostGIS SVN r4906 (the last one just now) on Ubuntu
9.10, and I have this error executing "make":

lwgeom_functions_basic.c: In function postgis_libxml_version:
lwgeom_functions_basic.c:205: error: POSTGIS_LIBXML2_VERSION
undeclared (first use in this function)
lwgeom_functions_basic.c:205: error: (Each undeclared identifier is
reported only once
lwgeom_functions_basic.c:205: error: for each function it appears in.)

xml2-config has been properly detected during configure. I can see
POSTGIS_LIBXML2_VERSION is defined in <src>/postgis/sqldefines.h, and
it has been added in the last revision of sqldefines.h.in file (this
is, r4885).

Attached is config.log, just in case. I executed "configure" without options.

Any clues?

Thanks in advance.

Best regards,
Jorge
-------------- next part --------------
A non-text attachment was scrubbed...
Name: config.log
Type: application/octet-stream
Size: 39543 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/postgis-devel/attachments/20091126/1ba32135/attachment.obj>


More information about the postgis-devel mailing list