[postgis-devel] PSC Vote to officially drop support for PostgreSQL 8.3 in PostGIS 2.0

Sandro Santilli strk at keybit.net
Thu Apr 14 04:54:11 PDT 2011

On Thu, Apr 14, 2011 at 07:02:46AM -0400, Paragon Corporation wrote:
> I hereby call a PSC Vote to officially drop support for PostgreSQL 8.3 in
> PostGIS 2.0.
> I think enough has been said on the topic that it is clear to me PostgreSQL
> 8.3 is becoming a bit of a burden to maintain 
> for both regression testing and as well as having to hold back on features
> introduced in newer versions of PostgreSQL.
> With this official drop we will then be available to take advantage of 
> 1) Window functions, CTES, variadic functions, RETURN QUERY EXECUTE, CASE in
> pl/pgsql, EXECUTE using, user-defined exceptions,
>   and a slew of other features itemized in PostgreSQL feature matrix
> http://www.postgresql.org/about/featurematrix
> 2) Not have to regress test against 8.3 any longer
> 3) Get rid of the stupid hack we have in place for pgxs
> 4) Get rid of that conditional logic we have in place for aggregation to
> handle versions that don't support windowing
> This is just one step, but my more aggressive requirement which I shall put
> in as a second PSC Vote, is to not support more than 
> 3 versions of PostgreSQL on any version of PostGIS unless there are
> extenuating circumstances.  More on that later.
> All PSC voters, please give your vote.
> +1 
> >From me.

+1 from me, given _previous_ debian stable has 8.4.7...


  ()   Free GIS & Flash consultant/developer
  /\   http://strk.keybit.net/services.html

More information about the postgis-devel mailing list