[postgis-users] 'server closed the connection unexpectedly' problem

strk at refractions.net strk at refractions.net
Fri Jan 28 00:04:20 PST 2005

On Thu, Jan 27, 2005 at 12:48:37PM -0800, Ionut Iordache wrote:
> Hello,
> I recently loaded large quantities of point data (close to half a
> billion records) into postgresql-7.4.6 with postgis-cvs version 1.0.0
> (as of 2005/01/13) and although the geometry creation and table
> loading went smoothly, I can't use any of the postgis functions on the
> POINT geometry columns!
> For example, when I try to run something like SELECT X(point_geom)
> FROM raw_data LIMIT 10; , I get the following error message:
> server closed the connection unexpectedly
>         This probably means the server terminated abnormally
>         before or while processing the request.
> The connection to the server was lost. Attempting reset: Failed.
> The same thing happens when I try to execute the Distance function for
> example. But if I do a SELECT AsText(point_geom), the records show up
> just fine...
> The log is not showing anything suspicious, except reporting that the
> child process was terminated by signal 10.
> I compiled postgres with LDFLAGS = -lstdc++ -lgcc and enabled geos and
> proj4 in postgis.
> Thanks for you assistance!

MM.. this is the second weird bug report related to points, but I 
can't reproduce this as well (PGGIS-1.0.0RC2 / PGSQL-7.4.3).

Can you try RC2, creating a *new* db ?
Can reproduce the bug on a single record ?
What OS are you using ? Which compiler used to build postgis ?


> -- 
> Best regards,
> -----------------------------------------------
> Dorel Ionut Iordache - <ionut at eps.berkeley.edu>
> UC Berkeley - Earth & Planetary Science Dept.
> _______________________________________________
> postgis-users mailing list
> postgis-users at postgis.refractions.net
> http://postgis.refractions.net/mailman/listinfo/postgis-users

More information about the postgis-users mailing list