[postgis-users] postgis on postgresql 8.2 vs 8.3

Stephen Woodbridge woodbri at swoodbridge.com
Tue Mar 24 20:20:48 PDT 2009

Hi all,

I have been holding back on upgrading my postgis installations from 
postgresql 8.2 to 8.3 because:

1) it seemed like there was a lot of new postgresql stuff to figure out 
in 8.3. What are the big changes I need to be aware of?

2) it seemed like there were initially some bugs and issues in 
postgresql 8.3 that I'm guessing have mostly been resolved

3) seemed like there have been or still are some postgis issues when 
running on postgresql 8.3

Is postgis and 8.3 safe and stable? are there specific bugs I need to be 
aware of? Do we have a list somewhere and work-arounds?

On my Debian box, I installed postgresql 8.2 long ago and have just held 
onto it, but the packages are no longer available in the archives and 
sometime later I added liblq5-dev package which appears to have come 
from 8.3 which is causing me headaches.

I can upgrade to 8.3, does this require a dump and restore, or is there 
a hot upgrade for postgis databases?

I can try and find a debian postgresql-8.2 source package and see if I 
can build the .deb files from that, but it seems like I will like need 
to upgrade to 8.3 regardless at some point.

So I looking for advice, feedback, whatever.


More information about the postgis-users mailing list