[postgis-users] postgis upgrade 1.4 to 1.5 sql file couldn't find $libdir/postgis-1.4

Paragon Corporation lr at pcorp.us
Wed Feb 24 03:41:35 PST 2010


>From the error its sounds  like the PostGIS 1.4 has been uninstalled in the
process of upgrading  to 1.5.  This is a big no no as if the old is
uninstalled before the database is upgraded, you run into this kind of issue
since they now use different file names.


-----Original Message-----
From: postgis-users-bounces at postgis.refractions.net
[mailto:postgis-users-bounces at postgis.refractions.net] On Behalf Of Mark
Sent: Wednesday, February 24, 2010 5:04 AM
To: PostGIS Users Discussion
Subject: Re: [postgis-users] postgis upgrade 1.4 to 1.5 sql file couldn't
find $libdir/postgis-1.4

Bruno Friedmann wrote:

> Doesn't know if already reported or what I'm doing wrong.
> In rpm (suppose to be the same with .deb) if you upgrade postgis from 
> 1.4 to 1.5 the postgis-1.4 referenced in function doesn't exist after
> As the default postgis upgrade script call the select 
> postgis_lib_version(); we get a fatal error
> ERROR:  could not access file "$libdir/postgis-1.4": No such file or 
> directory
> and all the process fail leaving normal user in trouble ...
> I've try to bypass it commenting the SELECT 
> postgis_major_version_check(); and get the sql executed ...
> Any comments ?

Hi Bruno,

Sorry but I'm not really sure what's happening here - I know that people
have tested the upgrade script when upgrading from 1.4 to 1.5 before the
final release and reported that it works.

I suspect you will need to talk to the maintainer of the .deb packages you
are using to find out why this is failing.



Mark Cave-Ayland - Senior Technical Architect
PostgreSQL - PostGIS
Sirius Corporation plc - control through freedom
t: +44 870 608 0063

Sirius Labs: http://www.siriusit.co.uk/labs
postgis-users mailing list
postgis-users at postgis.refractions.net

More information about the postgis-users mailing list