[Qgis-user] Problem compiling...

Tim Sutton tim at linfiniti.com
Sun Apr 23 05:46:38 EDT 2006


Hi

Also consider installing 0.7.4 rather which is the current stable version!

Regards

Tim

On 4/23/06, Hernán De Angelis <hernan.deangelis at glocalnet.net> wrote:
> Ciao Stefano,
>
> I do not know exactly what the problem is but I guess it might be related to
> the fact that the Qt version normally available as RPM for SuSE are compiled
> without thread support, which is required for QGIS. Try following these
> instructions (more or less as in the QGIS installation guide):
>
> QT
> Download, uncompress and untar in /usr/local/src
> Move everything to /usr/local/qt-X.X.X
> cd /usr/local/qt-X.X.X                                          # because it will be installed here
> ./configure -thread                                             # needs -thread to compile Qgis
> gmake                                                           #
> export PATH=$PATH:/usr/local/qt/bin                     # do not add to the path permanently, so
>                                                                         # doesn't mess the system's Qt
>
> Install QGIS as usual, but do not forget to add the following library calls in
> the ./configure line:
>
> CFLAGS=-I/usr/local/src/qt-X.X.X/include
> LDFLAGS=-L/usr/local/src/qt-X.X.X/lib
>
> Buona fortuna!
>
> Hernán
>
>
> El Sábado 22 Abril 2006 19.25, Stefano Rossi escribió:
> > Hi,
> > I'm trying to compiling Qgis-0.7.3 using a PC with Suse 10.0.
> > When I run 'make', my system start compiling then stop with this exit
> > status:
> >
> > (......)
> >
> > -qgsrunprocess.moc.o .libs/libqgis_la-qgsscalecalculator.o
> > .libs/libqgis_la-qgssimarenderer.o
> > .libs/libqgis_la-qgssinglesymrenderer.o
> > .libs/libqgis_la-qgsspatialrefsys.o .libs/libqgis_la-qgssymbol.o
> > .libs/libqgis_la-qgsuniquevalrenderer.o
> > .libs/libqgis_la-qgsuvalmarenderer.o
> > .libs/libqgis_la-qgsvectordataprovider.o
> > .libs/libqgis_la-qgsvectordataprovider.moc.o
> > .libs/libqgis_la-qgsvectorfilewriter.o .libs/libqgis_la-qgsvectorlayer.o
> > .libs/libqgis_la-qgsvectorlayer.moc.o .libs/libqgis_la-qgspgutil.o
> > -Wl,--rpath -Wl,/usr/lib/qt3/lib -Wl,--rpath -Wl,/usr/lib/qt3/lib
> > -L/usr/lib/qt3//lib /usr/lib/qt3/lib/libqt-mt.so -L/usr/local/lib
> > /usr/local/lib/libgdal.so /usr/lib64/libsqlite3.so
> > -L/usr/lib64/gcc/x86_64-suse-linux/4.0.2
> > -L/usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../x86_64-suse-linux/lib
> > -L/usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../lib64
> > -L/usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../.. -L/lib/../lib64
> > -L/usr/lib/../lib64 /usr/lib64/libstdc++.so -lm -lc -lgcc_s
> > /usr/lib64/gcc/x86_64-suse-linux/4.0.2/crtendS.o
> > /usr/lib64/gcc/x86_64-suse-linux/4.0.2/../../../../lib64/crtn.o
> > -Wl,-soname -Wl,libqgis.so.0 -o .libs/libqgis.so.0.0.1
> > /usr/lib/qt3/lib/libqt-mt.so: could not read symbols: File in wrong format
> > collect2: ld returned 1 exit status
> > make[4]: *** [libqgis.la] Error 1
> > make[4]: Leaving directory `/home/ste/qgis-0.7.3/src'
> > make[3]: *** [all-recursive] Error 1
> > make[3]: Leaving directory `/home/ste/qgis-0.7.3/src'
> > make[2]: *** [all] Error 2
> > make[2]: Leaving directory `/home/ste/qgis-0.7.3/src'
> > make[1]: *** [all-recursive] Error 1
> > make[1]: Leaving directory `/home/ste/qgis-0.7.3'
> > make: *** [all] Error 2
> > ste at linux:~/qgis-0.7.3>
> >
> >
> > My Qt version is 3.3.4 (installed from RPM's )
> >
> > Can anyone solve my problem ?
> _______________________________________________
> Qgis-user mailing list
> Qgis-user at lists.qgis.org
> http://lists.qgis.org/cgi-bin/mailman/listinfo/qgis-user
>


--
Tim Sutton

Visit http://qgis.org for a great Open Source GIS
Skype: timlinux
MSN: tim_bdworld at msn.com
Yahoo: tim_bdworld at yahoo.com
Jabber: timlinux
Irc: timlinux on #qgis at freenode.net



More information about the Qgis-user mailing list