[Qgis-user] python plugins

Alex Mandel tech_dev at wildintellect.com
Sun Oct 12 23:30:55 EDT 2008


JC Notter wrote:
> Hi,
> 
> I can't install Python plugins on  win2000 or winXP with 0.11 or 1.0
> except mapserver export and plugin installer.
> 
> Example :
> Impossible de charger le plugin postgps provoque une erreur lors de
> l'appel de sa méthode classFactory()
> 
> Traceback (most recent call last):
>   File "", line 1, in
>   File "C:/Documents and
> Settings/jcnotter/.qgis//python/plugins\postgps\__init__.py", line 23,
> in classFactory
>     from postgps import PostGPS
>   File "C:/Documents and
> Settings/jcnotter/.qgis//python/plugins\postgps\postgps.py", line 20, in
>     import psycopg2
> ImportError: No module named psycopg2
> 
> Python version:
> 2.5.2 (r252:60911, Feb 21 2008, 13:11:45) [MSC v.1310 32 bit (Intel)]
> 
> Python path:
> ['C:/Program Files/QGIS/./python', 'C:/Documents and
> Settings/jcnotter/.qgis//python/plugins', 'C:/Program
> Files/QGIS/./python/plugins', 'C:\\Program Files\\QGIS\\python25.zip',
> 'C:\\Python25\\Lib', 'C:\\Python25\\DLLs', 'C:\\Python25\\Lib\\lib-tk',
> 'C:\\Program Files\\QGIS', 'C:\\Python25',
> 'C:\\Python25\\lib\\site-packages']
> 
> Thank you
> 
> JC - La Reunion Island

You need to install the psycopg2 python library.
Here's a link to a windows installer
http://www.stickpeople.com/projects/python/win-psycopg/

Alex


More information about the Qgis-user mailing list