[Qgis-user] WMS bug?

Nikos Alexandris nikos.alexandris at felis.uni-freiburg.de
Wed Oct 22 11:45:20 EDT 2008


On Wed, 2008-10-22 at 17:37 +0200, Jürgen E. Fischer wrote:
> Hi Nikos,
> 
> On Wed, 22. Oct 2008 at 17:26:00 +0200, Nikos Alexandris wrote:
> > I am trying to retrieve (any) layer(s) from:
> >
> http://wms1.ccgis.de/cgi-bin/mapserv?map=/data/umn/germany/germany.map&&VERSION=1.1.1&REQUEST=GetCapabilities&SERVICE=WMS
> 
> You shouldn't add all those arguments.  Just use
> http://wms1.ccgis.de/cgi-bin/mapserv?map=/data/umn/germany/germany.map
> The additional arguments are added by QGIS automatically.
> 
> REQUEST=GetCapabilities is used to retrieve the available layers and
> REQUEST=GetMap is later used to retrieve the actual images - so adding
> GetCapabilities to the initial URL will at least break the image
> retrieval.

> Jürgen


Hi Juergen.

I did as you told. Still no luck. For example I try to add the
Bundeslaendernamen layer and I get:

Could not draw Germany because:

Request contains a SRS not offered by the server for one or more of the
Layers in the request.

The WMS vendor also reported: 

msWMSLoadGetMapParams(): WMS server error. Unsupported SRS namespace
(only EPSG and AUTO currently supported).

This is probably due to a bug in the QGIS program. Please report this
error.

Tried URL:
http://wms1.ccgis.de/cgi-bin/mapserv?map=/data/umn/germany/germany.map&SERVICE=WMS&VERSION=1.1.1&REQUEST=GetMap&BBOX=5.864170,47.274700,15.038900,55.056700&SRS=CRS:84&WIDTH=985&HEIGHT=836&LAYERS=Bundeslaendernamen&STYLES=&FORMAT=image/png&TRANSPARENT=TRUE


Kind regards, Nikos




More information about the Qgis-user mailing list