[Qgis-user] Version 1.3, Spatialite issues on Mac OS X and Linux

Carlo A. Bertelli (Charta s.r.l.) bertelli at charta.acme.com
Thu Oct 29 18:35:00 EDT 2009


Hello,
I thought it was only a problem on Os X, but now I think it's an issue
with some italian string and Mimas 1.3.
In the afternoon I upgraded my ArchLinux machine with Mimas 1.3 and I
tried it with the sample data from:
http://www.gaia-gis.it/spatialite/test-2.3.sqlite.gz
Unexpectedly I got the same result. This is the italian error message:
     Errore durante la connessione verso:

     sembra essere un DB SQLite valido, ma non uno SpatialLite ...
A possible translation sounds (sorry, I'm to lazy to verify it)
     Error during the connection to:

     seems to be a valid SQLite DB, but not a SpatiaLite ...
The name of the file (test_2.3.sqlite) does not come out. I wonder why.
Well, it could be my fault (all my machines refuse Spatialite, it' a
plot against me!), but I think there may be other reasons.

Carlo

--

On Thu, Oct 29, 2009 at 2:57 PM, William Kyngesburye
<kyngchaos at kyngchaos.com> wrote:
I haven't really paid attention to the spatialite thread.  Reading
spatialite works for me on Leopard and Snow, using the spatialite test
database.  Both full and standalone Qgis.

Can you reproduce the problem with the test database?

The /usr/local spatialite shouldn't cause problems for Qgis (my
builds), it's linked to the framework (OSX is very particular about
link paths, unlike linux).

Qgis (on OSX) also doesn't use the PATH.  OSX apps in general don't
use the PATH, or any env variables.

Note: I did create a "GDAL Complete" package a few weeks ago.


On Oct 29, 2009, at 3:59 AM, Carlo A. Bertelli (Charta s.r.l.) wrote:

Ciao,
as you could have seen on the list, my problem with spatialite files
is not solved. QGis 1.3 (QGis+frameworks and updated GDAL framework).
I know we should wait for GDAL 1.7 to write to spatialite, but I have
QGis 1.1 on Linux and it reads the same files that QGis refuses on
Leopard.
I think it's a problem with my installation, I have Spatialite
(command line tools, Gui and Gis) installed in /usr/local, maybe this
could cause a conflict, maybe it's only a $PATH issue, but I've tried
everything and it doesn't work. I have a map with a hundred layers and
the shapefile version (even if spatially indexed) is so slow in
comparison to spatialite that I really miss this feature.
TIA for any help provided.
BTW, may I put my 1+ on the all-frameworks idea again (even on Leopard)?
c


-----
William Kyngesburye <kyngchaos*at*kyngchaos*dot*com>
http://www.kyngchaos.com/

"I ache, therefore I am.  Or in my case - I am, therefore I ache."

- Marvin


More information about the Qgis-user mailing list