[Qgis-user] [solved] QGIS MapServer SVG

Marco Hugentobler marco.hugentobler at sourcepole.ch
Mon Sep 6 05:56:25 EDT 2010


Hi Horst

> But when I store the svg files in a folder like
> 
> $CMAKE_INSTALL_PREFIX/share/qgis/svg/mySymbols
> 
> it doesn't work.

Hm, strange. Could you have a look into the project file and check the svg file 
pathes? Normally, they should be something like:

<symbol outputUnit="MM" alpha="1" type="marker" name="0">
                        <layer pass="0" class="SvgMarker" locked="0">
                            <prop k="angle" v="0"/>
                            <prop k="name" v="/biology/Coniferous.svg"/>
                            <prop k="offset" v="0,0"/>
                            <prop k="size" v="6"/>
                        </layer>
                    </symbol>

So in your case "/mySymbol/symbol.svg"

See you in Barcelona,
Marco

Am Montag, 6. September 2010, um 09.54:12 schrieb Horst Düster:
> Hi Marco
> 
> Thank you very much. I use new generation symbology and your hints
> solved my problem when I store my svg files in
> 
> $CMAKE_INSTALL_PREFIX/share/qgis/svg
> 
> But when I store the svg files in a folder like
> 
> $CMAKE_INSTALL_PREFIX/share/qgis/svg/mySymbols
> 
> it doesn't work.
> 
> Greetings from Barcelona
> 
> Horst
> 
> Am 05.09.2010 12:32, schrieb Marco Hugentobler:
> > Hi Horst
> > 
> > Which renderer do you use (old symbology marker, new symbology svg marker
> > or any other)?
> > 
> > new symbology:
> > If you build with qgis trunk, the mapserver looks for svg symbols at the
> > QGIS install path ($CMAKE_INSTALL_PREFIX/share/qgis/svg). So normally,
> > it should not be necessary to move the svg files.
> > 
> > old symbology:
> > If you are using old symbology, the absolute svg pathes are in the
> > project file (assuming you save with 'absolute paths' in project
> > properties).
> > 
> > Regards,
> > Marco
> > 
> > Am Samstag, 4. September 2010, um 17.32:57 schrieb Horst Düster:
> >> Hi
> >> 
> >> I have created a QGIS project with some new SVG symbols. Now I want to
> >> serve this project as a WMS via QGIS MapServer, but all SVG symbols
> >> don't appear in the resultant WMS image. Now I'm in doubt where I have
> >> to put my SVG files on my server.
> >> 
> >> Any hint will be appreciated.
> >> 
> >> Horst
> >> _______________________________________________
> >> Qgis-user mailing list
> >> Qgis-user at lists.osgeo.org
> >> http://lists.osgeo.org/mailman/listinfo/qgis-user


-- 
Dr. Marco Hugentobler
Sourcepole -  Linux & Open Source Solutions
Webereistrasse 66, 8134 Adliswil, Switzerland
marco.hugentobler at sourcepole.ch http://www.sourcepole.ch
Technical Advisor QGIS Project Steering Committee


More information about the Qgis-user mailing list