[Qgis-user] New draft Ubuntu tutorial on QGIS server

Mayeul Kauffmann mayeul.kauffmann at free.fr
Mon Aug 22 20:19:53 EDT 2011


Hi Pirmin,
Thanks a lot! Packaged qgis_mapserv.fcgi works fine with mod_fcgid. I do
not remember where from I got the name of the mod_fastcgi package, maybe
from one of the links I mentioned. I believed that one mod was using a
daemon (fcig*d*) and the other not but that configuration was identical.
I've put a note in the wiki.
Still in my procedure I modified /etc/apache2/mods-enabled/fcgid.conf
At the end I'm not sure which mod I'm running !

(Side note: Googling a bit [1][2], I saw mod_fastcgi is somehow
considered less free but slightly faster)


Indeed I have a problem with the precompiled packages, mentioned here:
http://osgeo-org.1803224.n2.nabble.com/Ubuntu-Lucid-problem-td6501905.html
On same link, Robert S. mentioned having the same problem on another
version of amd64 Ubuntu. Now, the bug is only on one of my two Natty
machines (I have different "sudo apt-get upgrade" practices), so I might
find the reason... I will report if I do.

Thanks as well all for the edits in the wiki!

Mayeul

[1]
http://superuser.com/questions/228173/whats-the-difference-between-mod-fastcgi-and-mod-fcgid
[2]
http://blog.chty.org/post/2007/10/08/151-apache2-mod_fcgid-vs-mod_fastcgi#pnote-151-1


Le lundi 22 août 2011 à 21:58 +0200, Pirmin Kalberer a écrit :
> You're using mod_fastcgi and not mod_fcgid as the original tutorials
> do. 
> mod_fcgid comes with a working configuration. I installed QGIS server
> at least 
> on half a dozen machines with one apt-get install. If you find a
> problem with 
> the precompiled packages we should fix them.
> 
> Pirmin 



More information about the Qgis-user mailing list