[Qgis-user] Problems with saga module interface 0.17

Agustin Lobo alobolistas at gmail.com
Wed Oct 5 01:37:09 EDT 2011


Yes, right, thanks: that was the problem. I had both repos:
https://launchpad.net/~johanvdw/+archive/sagacvs
and ubuntugis-unstable
in the second machine. By some reason, the first repo had priority.
Removing the ~johanvdw repo, updating, removing saga et al.  and
installing again fixed
the problem. Perhaps this question should be mentioned in the web page
of the plugin.
(BTW, "the project's webpage" points to https://github.com/polymeris/qgis,
where no info on the plugin is available (at least easily available).

Agus

2011/10/4 Julien Malik <julien.malik at c-s.fr>:
> Hi,
>
> I had the same issue.
> Fixed it by taking the packages (saga and python-saga) from
> ubuntugis-unstable instead of
> https://launchpad.net/~johanvdw/+archive/sagacvs
>
> So :
> - aptitude remove saga python-saga
> - remove references of https://launchpad.net/~johanvdw/+archive/sagacvs in
> your /etc/apt/sources.list.d
> - aptitude update
> - aptitude install saga python-saga
>
> Should do the trick.
>
>
> The python bindings package in 2.0.7+svn1156+11~maverick1 is buggy :
> I can't import saga from a python interpreter, and get the same " undefined
> symbol" error.
>
>
> Julien
>
> Le 30/09/2011 11:09, Agustin Lobo a écrit :
>>
>> Unfortunately, actually still have the problem on another machine,
>> also with ubuntu lucid (and with the framework plugin of qgis
>> installed):
>> The puglin installer states:
>> The plugin is broken. Python said:
>> /usr/lib/python2.6/dist-packages/_saga_api.so: undefined symbol:
>> _ZNK23CSG_Regression_Multiple5Get_REv
>> alobo at alobo-laptop:~$ dpkg -l | grep saga
>> ii  libsaga
>> 2.0.7+svn1155+11~lucid1                         SAGA GIS development
>> files
>> ii  libsaga-dev
>> 2.0.7+svn1155+11~lucid1                         SAGA GIS development
>> files
>> ii  python-saga
>> 2.0.7+svn1155+11~lucid1                         SAGA GIS python
>> bindings
>> ii  saga
>> 2.0.7+svn1155+11~lucid1                         System for Automated
>> Geoscientific Analyses
>>
>>
>> alobo at alobo-laptop:~$ dpkg -l | grep qgis
>> ii  libqgis-dev                                   1.7.1-1~lucid1
>>                            Quantum GIS - development files
>> ii  libqgis1.7.1                                  1.7.1-1~lucid1
>>                            Quantum GIS - shared libraries
>> ii  python-qgis                                   1.7.1-1~lucid1
>>                            Python bindings to Quantum GIS
>> ii  python-qgis-common                            1.7.1-1~lucid1
>>                            Python bindings to Quantum GIS -
>> architecture-independ
>> ii  qgis                                          1.7.1-1~lucid1
>>                            Geographic Information System (GIS)
>> ii  qgis-api-doc                                  1.7.1-1~lucid1
>>                            Quantum GIS API documentation
>> ii  qgis-common                                   1.7.1-1~lucid1
>>                            Quantum GIS - architecture-independent data
>> ii  qgis-plugin-grass                             1.7.1-1~lucid1
>>                            GRASS plugin for Quantum GIS
>> ii  qgis-plugin-grass-common                      1.7.1-1~lucid1
>>                            GRASS plugin for Quantum GIS -
>> architecture-independen
>> ii  qgis-providers                                1.7.1-1~lucid1
>>                            collection of data providers to Quantum GIS
>> ii  qgis-providers-common                         1.7.1-1~lucid1
>>                            collection of data providers to Quantum GIS
>> - architec
>> ii  qgis-sqlanywhere1.7.1                         1.7.1-1~lucid1
>>                            Quantum GIS sql anywhere plugin and
>> provider
>>
>> Thanks
>>
>>
>> 2011/9/22 Agustin Lobo<alobolistas at gmail.com>:
>>>
>>> That was it, problem solved.
>>> Thanks
>>> Agus
>>>
>>> 2011/9/22 Giovanni Manghi<giovanni.manghi at gmail.com>:
>>>>
>>>> Have you installed the "framework processing manager" plugin?
>>>>
>>>> Cheers
>>>>
>>>> -- Giovanni --
>>>>
>>>>
>>>> On Thu, 2011-09-22 at 10:16 +0200, Agustin Lobo wrote:
>>>>>
>>>>> Since few days ago I cannot install the saga module interface 0.17.
>>>>> Qgis claims
>>>>>
>>>>> The plugin depends on some components missing on your system. You need
>>>>> to install the following Python module in order to enable it:
>>>>> processingplugin.processing
>>>>>
>>>>> I do have the saga python bindings 2.0.7+dfsg-0.5~lucid
>>>>>
>>>>> Any advice on what to do?
>>>>>
>>>>> Agus
>>>>> _______________________________________________
>>
>> _______________________________________________
>> Qgis-user mailing list
>> Qgis-user at lists.osgeo.org
>> http://lists.osgeo.org/mailman/listinfo/qgis-user
>>
>


More information about the Qgis-user mailing list