[Qgis-user] Passing label text to server

Marco Hugentobler marco.hugentobler at sourcepole.ch
Wed Oct 5 04:29:24 EDT 2011


Hi Mayeul

The syntax

&LABELA=test

works for me (text 'test' should appear in the label when used in a GetPrint 
request). There was however a bug that prevented the label to be shown in the 
capabilities document (fixed now in commit 
514d121ef1376083ff1bbaeffd22e97fe27a9e86 ).

Regards,
Marco

Am Dienstag, 4. Oktober 2011, 17.27:22 schrieb mayeul.kauffmann at free.fr:
> Hi,
> I am trying to passing label text to qgis server using the following:
> http://www.sourcepole.ch/web-based-printing-with-qgis-server
> "To replace text in composer labels, the label needs to have a text id (can
> be assigned in the print composer user interface of the composer label).
> The text to insert into the label can be passed in the GetPrint request
> with an additional parameter =text (of course, the label id should be
> different to the standard WMS parameters...)."
> 
> I defined the label id in the print composer as LABELA.
> I tried passing the parameter in the URL, doing the following:
> 
> &LABELA=test
> &LABELA:text=test
> 
> It has no effect on the label text. I do not quite understand "with an
> additional parameter =text". Thanks for the help!
> Mayeul
> _______________________________________________
> Qgis-user mailing list
> Qgis-user at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/qgis-user


-- 
Dr. Marco Hugentobler
Sourcepole -  Linux & Open Source Solutions
Churerstrasse 22, CH-8808 Pfäffikon SZ, Switzerland
marco.hugentobler at sourcepole.ch http://www.sourcepole.ch
Technical Advisor QGIS Project Steering Committee


More information about the Qgis-user mailing list