[Qgis-user] compiling QGIS version1.9.90-Alpha with GRASS 7.0

Paulo van Breugel p.vanbreugel at gmail.com
Tue Mar 20 16:40:11 EDT 2012


Hi,

I have compiled QIGS 1.9 successfully when building with GRASS 6.4 (on 
Ubuntu 11.10). However, when I try to build it with GRASS 7.0, I am 
running into problems.

In ccmake, I include the following when building with GRASS 6.4 (grass 
was build in usr/local/grass6.4.current):

GRASS_INCLUDE_DIR                
/usr/local/grass6.4.current/grass-6.4.2svn/include
GRASS_PREFIX                     /usr/local/grass6.4.current/grass-6.4.2svn
LIB_PATH in                      
/usr/local/grass6.4.current/grass-6.4.2svn/lib/libgrass_gproj.so

GRASS 7.0 is build in usr/local/grass7.current, thus used the following 
in the ccmake:

GRASS_INCLUDE_DIR                
/usr/local/grass7.current/grass-7.0.svn/include
GRASS_PREFIX                     /usr/local/grass7.current/grass-7.0.svn
LIB_PATH                         /usr/local/grass7.current/grass-7.0.svn/lib

However, when running configure, it apparently cannot find the lib_path, 
even though I am sure the path is correct (the field for LIB_PATH is put 
to LIB_PATH_NOT_FOUND).

I can still continue with make and make install and QGIS installs and 
runs fine, but without GRASS toolbox.

Any help would be appreciated.

Paulo
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://lists.osgeo.org/pipermail/qgis-user/attachments/20120320/f60b87e3/attachment.html


More information about the Qgis-user mailing list