[Qgis-user] Layers in qgs file not present in the Layers pane

Julian Bogdani jbogdani at gmail.com
Mon Sep 17 13:08:18 PDT 2012

I've posted a question on gis.stackexchange.com (http://gis.stackexchange.com/questions/33608/layers-in-qgs-file-not-present-in-the-layers-pane), and as promised there I'm sending here a qgis project file with a phantom layer to use for test.
The phantom layer is named: "plan01_2012" and references to: "./Planimetrie/2012/plan01_2012.tif" as you can see in lines 27 and following.
Opening the project with QGIS no error is showed for the missing reference, and no layer is shown in the Layers pane.
Checking better I can find a reference of this layer in the "Identifiable layer" tab of Project properties.
Saving project as.... will not purge the file.

As you can see in the same file other traces of older files are still present in the xml, for instance near lines126 and following: a list of vector layer with snapping turned on. This does not produce any error, but getting them removed when layer is removed is probably cleaner.

Julian Bogdani
jbogdani at gmail.com

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-user/attachments/20120917/9f310140/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: test.qgs
Type: application/octet-stream
Size: 12737 bytes
Desc: not available
URL: <http://lists.osgeo.org/pipermail/qgis-user/attachments/20120917/9f310140/attachment.obj>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/qgis-user/attachments/20120917/9f310140/attachment-0001.html>

More information about the Qgis-user mailing list