[Tilecache] ImportError: No module named mapscript

R. Ortner reinhard.ortner at edu.fh-kaernten.ac.at
Fri Dec 7 03:16:48 EST 2007


I tried to run Tilecache but only get pink tiles and an error 500, so i
tried a python script to test my python installation (a helloworld.cgi is

Here´s the test.py code:

import mapscript

# Set the map file to use
mapfile = "geoland_test.map"

# Create a mapObj, initialized with the mapfile above
mapobject = mapscript.mapObj(mapfile)

# Create an imgObj that has an image of the map
mapimage = mapobject.draw(  )

# Save the mapimage to a file

(the test.py and the folder is chmod 755)
(Installed Mapserverversion 4.10,2)
(Mapscript version: ($Revision: 6000 $ $Date: 2007-04-04 11:56:02 -0500
(Wed, 04 Apr 2007) $))

The problem is, I get following error message in the apache error_log:
  ImportError: No module named mapscript

I gess I have to install somehow a mapscript module for python?!

Where can I get such module and how do I install that?

View this message in context: http://www.nabble.com/ImportError%3A-No-module-named-mapscript-tf4960811.html#a14208485
Sent from the TileCache mailing list archive at Nabble.com.

More information about the Tilecache mailing list