[Tilecache] Re: TileCache and Mapnik - it doesn't work

Dane Springmeyer blake at hailmail.net
Mon Sep 6 19:35:59 EDT 2010


It sounds like a PYTHONPATH problem whereby the apache user does not have access to the same environment settings as your normal user. Maybe you can try setting the PYTHONPATH to the mapnik site-packages directory as a "system" setting rather than "user"? Also, confirm that you are running the same python version for TileCache and Mapnik's python bindings.


On Sep 6, 2010, at 4:24 PM, Steve L. wrote:

> Hello Chris,
> thanks for your answer, but it didn't quite help me with my problem.
> You wrote that there might be something in the Apache config, which isn't
> correct. I think there are some people, who got it to work on an Windows
> machine, maybe they can help me?
> How do I point to the Mapnik library? I searched the mailing-list but did
> not find a problem similar to mine.
> Maybe it is just a Path Problem, but I think I got the Paths correct:
> My entry for Mapnik ist: Path C:\mapnik-0.7.1\lib and
> the Pythonpath: C:\mapnik-0.7.1\python\2.5\site-packages
> Maybe there has to be an entry for tilecache too? I'm not sure.
> In my opinion that should do it for tilecache and Mapnik to work together.
> If someone knows how do get it work, that would be great.
> I have been looking and trying out for days now.
> Thanks
> Steve
> -- 
> View this message in context: http://osgeo-org.1803224.n2.nabble.com/TileCache-and-Mapnik-it-doesn-t-work-tp5490598p5503274.html
> Sent from the TileCache mailing list archive at Nabble.com.
> _______________________________________________
> Tilecache mailing list
> Tilecache at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/tilecache

More information about the Tilecache mailing list