[Ubuntu] Change of libgdal1 to libgdal1h - dependency problems

Jerome Villeneuve Larouche jlarouche at mapgears.com
Mon Jul 8 13:08:09 PDT 2013

Hi Pedro,

The changes are coming from Debian, see
for the explanation.

There was also a big change in postgis packaging. Some name have 
changed, like postgresql-9.1-postgis which is now 
postgres-9.1-postgis-2.0. So packages depending on it have to be rebuild 
(They probably need postgresql-9.1-postgis2.0-scripts which contains all 
the sql files). Normally they should all be updated for Lucid/Precise 
now, but for packages like OTB I can't tell because I'm not maintaining 

Sorry for the inconvenience this updated is causing, I'm sure it'll all 
be back to normal soon :).


On 13-07-08 03:53 PM, Pedro Venâncio wrote:
> Hi,
> After an update of GDAL to v1.10 through ubuntugis-unstable, I have a lot of problems with package dependencies from libgdal1. This package was, apparently, replaced by libgdal1h (gdal 1.10.x) but there are many programs that are not understanding it as a substitute (eg OTB, pgrouting which depends on the package postgresql-9.1-postgis, etc..).
> Is there any reason for libgdal1 have been changed to libgdal1h, since there are many packages that use libgdal1 as dependency?
> Thank you very much!
> Best regards,
> Pedro
> _______________________________________________
> UbuntuGIS mailing list
> Ubuntu at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/ubuntu
> http://trac.osgeo.org/ubuntugis/wiki

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.osgeo.org/pipermail/ubuntu/attachments/20130708/3e74f324/attachment.html>

More information about the Ubuntu mailing list