[Benchmarking] Pgsql set up

Cédric Briançon cedric.briancon at geomatys.fr
Fri Aug 6 08:48:12 EDT 2010

Le 29/07/2010 21:04, Paul Ramsey a écrit :
> Host
> User postgres
> Password postgres
> Access only available from the local network
> Tables
>    Building
>    Contour
>    Industry
>    Motorway
>    Point_labels_for_geometry
>    Point_labels_no_geometry
>    Ramp
>    Road
>    Settlement
>    Track
> P.
> _______________________________________________
> Benchmarking mailing list
> Benchmarking at lists.osgeo.org
> http://lists.osgeo.org/mailman/listinfo/benchmarking
Hi Paul,

I've imported the shapefiles into a personal database, using the 
encoding LATIN1 (ISO-8859-1) as you adviced me by IRC. The import has 
worked, but I have strange characters in the point label tables.
So I have checked on the database server for the benchmarking session, 
and it displays the same wrong character.

If you want to check on the benchmarking server, here is a copy of my 
shell session:

psql -U postgres

postgres=# \c benchmarking
psql (8.4.4)
You are now connected to database "benchmarking".
benchmarking=# select etiqueta from point_labels_for_geometry where gid='4';
  Peña Gacha
(1 row)

In the etiqueta field, it seems the result has wrong encoding character.
I'm not a specialist on this domain, could you please check there is 
something wrong here?
I've also tried to move my bash shell into en_US.iso88591 (with the LANG 
value), just to check but the result is the same for this postgresql 
I don't know if the database needs a "clientencoding" properties, maybe 
it can help. Or maybe the database should be in another encoding before 
the shp2pgsql use.

This specific is the one that we request by the WMS style on this layer, 
so if the database has wrong characters in it, the WMS will display it 
as it is, that's why I have a particular interest for it.

Anyway, thanks for the import into postgis.
Cédric Briançon.

More information about the Benchmarking mailing list