[OSGeo-Discuss] strange issue PostGis + Mapserver

Pedro-Juan Ferrer Matoses pferrer at osgeo.org
Fri Jul 16 04:47:41 PDT 2010

Hello everybody and excuse me for the crossposting,

I'd like to report a strange issue I have with Mapserver and PostGis
in order to get some new "ideas" on the problem.

* Ubuntu Karmic Server
* Mapserver 5.4.2
* Postgres 8.3.9
* Postgis 1.5.1
* Postgis table with +30000 Multipolygon records, this layer was
originally in a shapefile, which I don't have, and I know that the
shapefile was build from smaller ones. I'm publishing the layer with a

* If I make a GetFeatureInfo on the WMS, I get the info only in some
zones and in other zones I get an "Content-type:
application/vnd.ogc.se_xml" error. I suspect that the zones are
related to the original smaller shapefiles that made the original and
bigger shapefile.

* The XML error has the "ServiceException" tag empty, there is no
other trace of error.
* If I export the layer as shapefile and publish the shapefile as WMS
I get the info in all the zones.

[Things I've tried]
* I tried  serving the WMS in DEBUG mode but the error log doesn't
report anything.
* I tried exporting and importing the shapefile again from/into
Postgis, using gvSIG  and/or shp2pgsql, nevertheless I get the same
* I've googled the mailing lists, I've seen that some SQLServer2008
users report something similar, but the solution was migration to
PostGIS :(

Has someone seen/experienced/reported something similar?

Tanks in advance.

Pedro-Juan Ferrer Matoses
Valencia (EspaƱa)

More information about the Discuss mailing list