[El] Re: gis centos5.5 (GDAL 1.7.2)

Hatzopoulos, Nikolaos hatzopou at chapman.edu
Fri Aug 6 11:47:05 EDT 2010

it seems to be missing this flag from your compilation:

# fix ruby flags
sed -i -e "s/\$(LD)/g++ -L..\/..\/.libs\/ $RPM_OPT_FLAGS/g" swig/ruby/RubyMakefile.mk

you can tried:
# fix ruby flags
sed -i -e "s/\$(LD)/g++ -L..\/..\/.libs\/ $RPM_OPT_FLAGS -fPIC/g" swig/ruby/RubyMakefile.mk


-----Original Message-----
From: Peter Hopfgartner [mailto:peter.hopfgartner at r3-gis.com]
Sent: Fri 8/6/2010 7:56 AM
To: Hatzopoulos, Nikolaos
Cc: el at lists.osgeo.org
Subject: RE: [El] Re: gis centos5.5 (GDAL 1.7.2)

Hi Nikolas,

I've tried to recompile you src.rpm on a current CentOS 5.5, 64 bit, but I fail miserably. I get:

g++ -L../../.libs/ -O2 -g -m64 -mtune=generic  -Xcompiler -shared -L/usr/lib64  -L/usr/lib64 -lgeos_c -L/usr/lib -lsqlite3 -lodbc -lodbcinst -L/usr/lib -lexpat -L/usr/lib -lxerces-c -lpthread -lNCSEcw -lNCSCnet -lNCSUtil -ljasper -lhdf5 -L/usr/lib64/hdf -lmfhdf -ldf -logdi -lgif -ljpeg -lgeotiff -ltiff -lpng -lnetcdf -lcfitsio -lpq -L/usr/lib64 -lpq -lz -lpthread -lm -lrt -ldl        -rdynamic -L/usr/lib64/mysql -lmysqlclient -lz -lcrypt -lnsl -lm -lssl -lcrypto -L/home/rpmbuild/rpmbuild/BUILD/gdal-1.7.2 -lgdal -lruby gdal_wrap.o -o gdal.so

g++: unrecognized option '-Xcompiler'

/usr/bin/ld: gdal_wrap.o: relocation R_X86_64_32 against `a local symbol' can not be used when making a shared object; recompile with -fPIC

gdal_wrap.o: could not read symbols: Bad value

collect2: ld returned 1 exit status

make[3]: *** [gdal.so] Error 1

make[3]: Leaving directory `/home/rpmbuild/rpmbuild/BUILD/gdal-1.7.2/swig/ruby'

make[2]: *** [build] Error 2

make[2]: Leaving directory `/home/rpmbuild/rpmbuild/BUILD/gdal-1.7.2/swig/ruby'

make[1]: *** [build] Error 2

make[1]: Leaving directory `/home/rpmbuild/rpmbuild/BUILD/gdal-1.7.2/swig'

make: *** [swig-modules] Error 2

error: Bad exit status from /home/rpmbuild/rpmbuild/tmp/rpm-tmp.76173 (%build)

RPM build errors:

    Bad exit status from /home/rpmbuild/rpmbuild/tmp/rpm-tmp.76173 (%build)

Could you give ma any hint how to get through this?



--------Mathieu Baudier <mbaudier at argeo.org> wrote--------

Subject: [El] Re: gis centos5.5 (GDAL 1.7.2)

Date: 05.08.2010 10:16

>Hi Nikolaos,


>> I compiled gdal 1.7.2 on centos5.5 x86_64 (without ldap support)

>> ftp://ftp4cast/nickhatz/gis_repo/Centos5.5/


>I cannot open this URL.

>It seems like a host on your LAN (no .edu/.org/.com, etc.).

>Do you have a public address?


>> what do you say?


>I say it's cool.

>I would be happy to have a closer look.

>How did you build it? From scratch? By updating the sources in one of

>our SRPMs? (see below)

>Do you have any other GIS RPMs in this repo?


>As you may know we are putting in place a repository of RPM for GIS on

>Enterprise Linux:


>(the structure will soon change as we will have a 'stable' and a

>'testing' repository)


>You are welcome to contribute!


>I put the mailing-list in cc., you can join it at

>http://lists.osgeo.org/mailman/listinfo/el .


>@list: GDAL 1.7.2 seems a good candidate to be put in a 'testing' repo

>while we keep 1.6.3 in a 'stable'

>What are your thoughts on GDAL minor version updates in general?






>el mailing list

>el at lists.osgeo.org



More information about the el mailing list