[El] Missing dependencies

Micha Silver micha at arava.co.il
Tue Aug 24 05:05:19 EDT 2010

On Sat, 21 Aug 2010 12:49:48 +0200
Mathieu Baudier <mbaudier at argeo.org> wrote:

> > Running 'rpmbuild --short-circuit -bi grass.spec' creates the
> > binaries, but not the final rpm.
> Maybe some install statements are missing.
> Could you please attached your modified spec file, so that we can
> have a look?

Hi Mathieu:
I've put a bit more time into both GRASS and QGIS, and I'd say I've got
about the same 75% functionality that the elgis packages offer: QGIS
with no python support (a big limitation) and GRASS still without the
digitizer and without nviz (a minor annoyance).

Trying QGIS, I first install the epel python26 packages, and using some
ugly hacks I managed to get QGIS 1.5 compiled and working, but I still
get a mismatch between python2.6 and the version of sip on CentOS, so
python is still disabled. Here are the (not-recommended!) steps I tried:
sudo yum install qwt qwt-devel
sudo yum install python26 python26-devel python26-tools
export PYTHONPATH=/usr/lib/python2.6/
alias python=/usr/bin/python2.6
# ugly soft links to cover for absent python packages
sudo ln
-s /usr/lib/python2.4/site-packages/PyQt4 /usr/lib/python2.6/site-packages/
sudo ln
-s /usr/lib/python2.4/site-packages/sip* /usr/lib/python2.6/site-packages/
# Download and untar QGIS source 
# create build directory and cd to build
cmake -L -DCMAKE_INSTALL_PREFIX:PATH=/usr/local/qgis-1.5 \
	-DGRASS_PREFIX=/usr/grass-6.4.0svn/ \ 
	-DGDAL_LIBRARY:STRING=/usr/lib/libgdal.so  .. 
# edit shebang line in /usr/bin/pyuic4 to point to python2.6 
make install
It worked but python disabled in QGIS :-(

Now for GRASS, here are the diffs to the grass.spec and the original
Makefile in the source tarball:

diff grass.spec.orig grass.spec
< BuildRequires:  unixODBC-devel mysql-devel postgresql-devel
sqlite-devel ---
> BuildRequires:  unixODBC-devel mysql-devel postgresql84-devel
> sqlite-devel
< BuildRequires:  proj-devel geos-devel blas-devel lapack-devel
fftw2-devel gdal-devel ---
> BuildRequires:  proj-devel geos-devel blas-devel lapack-devel
> fftw-devel gdal-devel
< #%%   --with-python \
>    --with-python \

and after opening the source tarball, I changed the Makefile:
diff Makefile.orig Makefile
>       gui/wxpython/vdigit \
>       gui/wxpython/nviz

but this fails on creating the subdirs: gui/wxpython/nviz and
gui/wxpython/vdigit.  I don't understand the make process well enough
to find why the sub-directories are not created.

In any case in the past I've compiled GRASS successfully on Fedora,
including the vector digitizer by:
1) Adding to the configure line --with-cxx --with-python --with-wxpython
2) After running 'make' I go into the subdirs gui/wxpython/vdigit and
gui/wxpython/nvix and run 'make' inside each. Then finally 'make
install' from the top source directory and it works.

Bottom line, as you said, we should wait for CentOS 6...


> This mail was received via Mail-SeCure System.

More information about the el mailing list