[fdo-dev] Re: Boost build problem from SVN-head

Traian Stanev traian.stanev at autodesk.com
Thu Aug 17 10:08:06 EDT 2006

I haven't had much success with the Cygwin svn either. You're better off
downloading the svn client that's built against regular Windows.

-----Original Message-----
From: Frank Warmerdam (External) 
Sent: Thursday, August 17, 2006 10:03 AM
To: Frank Warmerdam (External)
Cc: FDO Developers
Subject: [fdo-dev] Re: Boost build problem from SVN-head

Frank Warmerdam wrote:
> Folks,
> I'm trying to build the third party stuff for FDO from SVN head and I 
> get the following:
> Project
> "C:\warmerda\fdocore\Thirdparty\boost_1_32_0\boost_1_32_0.vcproj" 
> (Build
> target(s)):
> Target Build:
>     C:\warmerda\fdocore\Thirdparty\boost_1_32_0\boost_1_32_0.vcproj : 
> warning MSB4098: MSBuild is invoking VCBuild to build this project. 
> Project-to-project references between VC++ projects (.VCPROJ) and 
> C#/VB/VJ# projects (.CSPROJ, .VBPROJ, .VJSPROJ) are not supported by 
> the command-line build systems when building stand-alone VC++
> Projects that contain such project-to-project references will fail to 
> build. Please build the solution file containing this project instead.
>     C:\Program Files\Microsoft Visual Studio 
> 8\Common7\IDE\..\..\vc\vcpackages\vcbuild.exe
> C:\warmerda\fdocore\Thirdparty\boost_1_32_0\boost_1_32_0.vcproj
> "debug|Win32"
>     Project : error PRJ0019: A tool returned an error code from 
> "Performing Makefile project actions"
> Done building target "Build" in project "boost_1_32_0.vcproj" --
> I tried using visual studio but this didn't seem to work.  Does anyone
> a suggestion on what I need to do?


In follow up to my own problem:

  o The warning MSB4098 is normal and not really a problem.

  o I looked in the boost\BuildLog.htm (with a real browser since it is
    some sort of funky 16bit character set) and saw an "Access Error"
    without any indication of on what.  But I also saw that "bjam" was
    executed to do the build.

  o I tried running bjam.exe and got an access error.  It seems my
    SVN client extracted the executable without execute permissions for

When I set execute permission on the .exe things worked ok.

So lessons:

  o If there are things like .exe's in SVN there are some limitations on
    SVN clients will work properly.  With MapGuide I found the Cygwin
svn was
    unable to handle some character set conversion problem on checkout
and I
    had to upgrade to TortiseSVN.  Perhaps we need some note about this

  o In MSBUILD problems, do dig into the BuildLog.htm to find out what
is going

  o Perhaps we could have the build scripts include an action to make
    files executable to work around this sort of problem.

Now, on to figure out why my actual fdo build isn't working.  Somehow I
always pick the wrong way to do things!

Best regards,
I set the clouds in motion - turn up   | Frank Warmerdam,
warmerdam at pobox.com
light and sound - activate the windows | http://pobox.com/~warmerdam
and watch the world go round - Rush    | President OSGF,

To unsubscribe, e-mail: dev-unsubscribe at fdo.osgeo.org
For additional commands, e-mail: dev-help at fdo.osgeo.org

More information about the Fdo-internals mailing list